Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a Dell Latitude E6520 and I'm using the E Port dock to get a DisplayPort output to plug into a Dell U2711 monitor.

The native resolution of the monitor is 2560x1440 and I'd really like to get it to that resolution.

I'm using the Nvidia X settings thing and I the highest resolution listed is 1920x1080. Is it worth hand editing the xorg.conf file maybe? Or am I just out of luck?

The graphics card (NVIDIA NVS 4200M 512MB) seems to be functioning ok. Unity and the composite effects are all working and pretty snappy.

I did have to disable something called Optimus in the BIOS but I gather this is just a power saving thing.

share|improve this question
add comment

3 Answers 3

From what I understand, "Optimus" is the technology, which decides, when to use the dedicated Nvidia graphics card and when to use the on-board intel graphics chip.

https://secure.wikimedia.org/wikipedia/en/wiki/Nvidia_Optimus:

For now, Nvidia has no plans to support Optimus on Linux. This makes hardware acceleration impossible by the Nvidia adapter. However, Martin Juhl is working on an Open source alternative called Bumblebee (https://github.com/MrMEEE/bumblebee).

You might want to check out the Bumblebee project, it seems to me, that this is, what you need to use your Nvidia graphics card.

share|improve this answer
1  
Thanks. I have a feeling that info might date back to before you could disable Optimus in the BIOS. It seems to me that disabling it enabled hardware acceleration via Nvidia. Before I did that there was no hardware acceleration at all. I'm fairly confident the card is working as expected now, I'd just like to know how to get it to full resolution. –  Tom Martin Sep 1 '11 at 21:53
    
Looking at the related questions, it seems several people are having the same issue with the Nvidia driver. Maybe there is a bug in the driver, so you can't access the highest resolution on your graphics card. You could try using the non-proprietary nv driver. Or maybe your monitor is not recognized properly. To fix this, have a look at this answer: askubuntu.com/questions/19954/… –  ChrisiPK Sep 2 '11 at 8:52
add comment

I had the same problem, my monitor would only output at 1600x1050. In addition the display port would not work and dual-link DVI only outputted the above resolution. What I ended up doing was updating the bios to revision A07. This resolved the display issue. Now I'm just trying to figure out how to get the docking station to work correctly (i.e. having the monitors switch on the fly).

Luis

share|improve this answer
add comment
up vote 0 down vote accepted

When I upgraded to Ubuntu 11.10 I was able to select the full resolution in the nVidia settings dialogue and everything worked perfectly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.