Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu Lucid with kernel 2.6.35 on a Thinkpad T61. In the power management settings I set it up to blank the display after 2 minutes. This works right after I log in, but after a few hours of active use, closing applications and then walking away from the computer, the display won't ever blank until I log out and log in again. The screensaver, although enabled, activates only in the first few hours after logging in.

What can be the root cause of the problem?

  • Incorrect screensaver or blanking settings cannot be the root cause, because these features work with the current settings right after logging in.

  • User-visible applications (such as Firefox, Chrome, their Flash player or Skype) cannot be the root cause, because the screen doesn't blank even after I quit these. (Verified with ps ax.)

Is there a workaround?

How do I debug the problem? Is there a tool which displays a counter like 1:57 seconds until blanking?

Please note that in this question I don't care about sleep, suspend or hibernate -- I care only about blanking the display.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I've searched for hours and found two ways:

Bash Scripts: Here is a thread that has 2 ways. Post #7 is when the answers begin: http://ubuntuforums.org/showthread.php?p=11738584#7

Easier way: Stop using gnome-power-manager:

  1. Install xfce4-power-manager
  2. Don't do anything to gnome-power-manager. Keep it in your system and ignore it like an annoying classmate. If you uninstall it, it will uninstall vital Ubuntu components.
  3. Go to System > Preferences > Startup Applications
    • Find: Power Management and click Edit. Change: gnome-power-manger to xfce4-power-manger. Save. (If you add in a custom Startup Applications entry for xfce4-power-manager, it may not start. Don't know why that happens. Editing the original Power Management is more reliable.)
  4. Hit Alt-F2 and run command xfce4-power-manager-settings. Change the settings.
  5. Reboot.
  6. Downside:
    • The screen will darken/turn off during video apps because gnome-screensaver does not tell xfce4-power-manager to inhibit itself during video playback.
    • If the xfc4-power-manager works, but is unreliable, you might want to upgrade to version 1.0+ using this ppa: ppa:alexx2000/xfce
    • If that still doesn't work, change gnome-screensaver to xscreensaver.
    • If that still doesn't work, use my last option: Spend more than a week trying out different OSes, give up, and upgrade to Ubuntu/Gnome-Shell 11.10. This problem has been solved there. Interestingly, Ubuntu 11.10 uses xscreensaver and not gnome-screensaver.
share|improve this answer
    
Thank you for this well-researched answer. I always wanted to get rid of gnome-power-manager, but I didn't know my options to replace it with. –  pts Mar 11 '12 at 8:03
add comment

You could start by checking that gnome-screensaver is still running:

[user@host] ~> ps ax |grep screen
 1939 ?        Ss     0:06 gnome-screensaver

If it is running kill it with 'kill [pid]' and restart it with 'gnome-screensaver --debug'

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.