Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just downloaded the latest version of Blender from the website on to my Xubuntu machine, when I open it, I get this: screenshot The screenshot below is a zoomed in version of the top left of the screen, as you can see, the (i) icon is displayed fine but the text is unreadable.

screenshot

Images appear fine but the text is very distorted. What other information should I provide that may help to solve this problem? Thanks in advance, ell.

Edit: I downloaded the Linux x86-32 package from the blender website(pre-compiled binaries) and extracted it, I've tried running plain blender (just open the blender executable) as well as running the blender-softwaregl script but both give the same results. Both of them give the following results when run from the terminal:

ndof: dead zone set to 0.10
connect failed: No such file or directory
ndof: spacenavd not found
Info: Config directory with "startup.blend" file not found.
found bundled python: /home/elliot/Downloads/blender-2.59-linux-glibc27-i686/2.59/python
share|improve this question
    
What is "distorted"? The characters? Did you checked the language option? –  desgua Sep 1 '11 at 18:07
    
All of the text is distorted as if each character has been split horizontally and shifted in both directions, it also appears like there are duplicates of each character that blend into each other. Is the image attached correctly? –  ell Sep 1 '11 at 18:14
    
if you change back to the default "greybird" theme does the problem disappear? –  fossfreedom Sep 1 '11 at 18:34
    
The theme is currently greybird, the screenshot just doesn't show the window border. Note: distortion happens in both windowed and fullscreen modes –  ell Sep 1 '11 at 18:42
    
Now, with the zoomed image, I could see it. –  desgua Sep 1 '11 at 19:45

5 Answers 5

up vote 2 down vote accepted

The question mentioned that blender was installed from the website - I presume this means that it was compiled. It could be a compilation/incompatibility through this method of installation.

Installing from this PPA into my Xubuntu virtual guest displayed blender v2.59.2 correctly:

enter image description here

installation

sudo apt-add-repository ppa:cheleb/blender-svn
sudo apt-get update
sudo apt-get install blender

Graphics Issues

With older graphics cards you do have a couple of options to try:

  1. Uplift your graphics stack using the x-swat PPA
  2. Uplift both your graphics stack and kernel using the x-edgers PPA

Both obviously are less tested and can themselves break your system - so have a good backup BEFORE you attempt them. Using something like clonezilla to backup your system to and external hard-drive.

For suggestion 1:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update && sudo apt-get upgrade

For suggestion 2: this is an unstable PPA - whilst it can resolve graphical issues - accepting updates from the PPA can leave you with black-screen

sudo add-apt-repository ppa:xorg-edgers/ppa 
sudo apt-get update && sudo apt-get upgrade
sudo apt-get install linux-headers-3.0.0-11 linux-image-3.0.0-11-generic 

Then open software-sources and untick the edgers PPA so that further updates are not received in the future.

share|improve this answer
    
This installation also has problems, I will install another driver and if that doesn't work I think I will mark Roland's answer as correct because he seems to have found the problem, thanks for the suggestion anyway –  ell Sep 12 '11 at 15:20
    
@ell - I can't see in your question whether you are using the proprietary driver or the open-source driver. If you are using the open-source driver you have some options to try - for example - updating to the latest X-Stack via the x-swat PPA, updating both the kernel & using the x-edgers PPA. Really this is up-to you what you want to try. –  fossfreedom Sep 12 '11 at 15:38
    
Well It's on a new xubuntu install so I guess its the open source drivers but I'm not sure. But now, after trying to install fglrx (the proprietary ati drivers, correct?) using Synaptic I now get this: name of display: :0.0 Segmentation fault But a segmentation fault is a pretty serious error isn't it? Is it likely that I have installed it incorrectly? I also get a segmentation fault when running blender. –  ell Sep 12 '11 at 15:51
    
@ell - if its a new install you are very correct - you will be using opensource drivers - my first answer (x-swat) is probably the first thing I would have tried. I would not try to download the fglrx drivers since I think ATI do not support your particular graphics card. I'll get back to you a little later to confirm this. –  fossfreedom Sep 12 '11 at 16:00
1  
@ell - your ATI radeon 9600 can only use ATI Catalyst v9.3 from the ATI website. I'm not aware of whether this works with linux kernel v3.0 - if this is the driver you were using with original 11.04 and you got the segmentation fault, then most probably you only can use open-source drivers. support.amd.com/us/gpudownload/linux/Legacy/Pages/… –  fossfreedom Sep 13 '11 at 10:03

Blender has various options in the user preferences dialogue that might be able to help you. If all else fails, it might be a bug with your graphics card/chip/drivers.

blender preferences opengl

This first window contains various OpenGL options. You can try disabling Text Antialiasing.

enter image description here In this second window, you can try changing the path where your system is finding its fonts.

If neither of these work, ensure that you have the proprietary graphics drivers for your card (if you have an ATI/AMD or nVidia card/chip that is recent enough to require them).

If installing another driver still does not fix the problem, then it is likely a bug in blender, and you would need to report a bug on their bug tracker.


In light of your comment:

If your graphics are old, you will probably encounter a lot of bugs with Blender, especially with ATI cards, which are notorious for blender bugs. There is essentially nothing more you can do but report a bug.

share|improve this answer
    
Hi, I've just tried turning off anti aliasing and it hasn't worked. I'm not sure exactly what graphics card is in, but its a pretty old machine, if I remember correctly its an ATI Radeon 9600?Its late for me here so I will try in the morning, thanks for the answer though, hopefully it will work! –  ell Sep 11 '11 at 21:44

I had the same problem. My Blender looks like ell one. I tried different solutions but just that one works for me:

Add PPA from that web: https://launchpad.net/~xorg-edgers/+archive/ppa

(In Synaptic Package Manager go to Settings then Repositories, it will open Software Source window, go to Other Software press Add to add new repository. Close it. Reload Synaptic.)

In Synaptic Package Manager search for xserver-xorg-video-radeon. (in my case it was install but had question mark next to it) and Mark for Upgrade, Apply changes. My Blender looks perfect after that.

Update all system. (go to system => administration => update manager)

Herby Pepper /newbie/

/sorry for all details but hope newbie's will find it useful too/

share|improve this answer
    
Thank you, this fixed it, but I think a command line version was suggested and I just failed to do it properly. I'm not sure who to accept. –  ell Sep 20 '11 at 19:11
    
As long as it got fixed that's good. thanks for letting me know. I am not experienced enough to advise by command line. –  Herby Pepper Sep 20 '11 at 19:22

I did not encounter this but I remember from other OpenGL applications that they don't behave well with Xfce's built-in compositor.

If you use it, which I'm guessing from xubuntu, try to turn it off: Settings/Settings Manager/Window-Manager Tweaks, Compositor Tab.

If you use Compiz, try plain xfwm4 --replace and turn compositing off.

share|improve this answer
    
I'm on my phone at the moment but I will try that as soon as I can! thanks :) –  ell Sep 13 '11 at 22:54
    
This didn't work either. Maybe I should just accept that I can't run blender. –  ell Sep 16 '11 at 15:48

I had problems with that too... you have the restricted extras installed? if not, try installing them, they solved it for me...

sudo apt-get -y install ubuntu-restricted-extras
share|improve this answer
    
I'm afraid that didn't seem to change anything –  ell Sep 15 '11 at 16:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.