Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

No player seems to support the Real Media codecs I need. I have even tried VLC and movie player, both of which failed.

share|improve this question

You may be in the need to install Restricted Extras on your system. You can do it by dropping sudo apt-get install ubuntu-restricted-extras in a terminal

Additionally, information provided in this page can be useful, specially this which refers to Real Media, posted here for your convenience.


RealPlayer is a media player originally developed by RealNetworks in 1995. It supports a number of audio and video codecs such as realaudio, realvideo, mp3, ogg vorbis and theora, h263, and AAC. RealPlayer for Linux is based on the open-source Helix Player which can be found at the Helix Community Website.

Please Note: RealPlayer is proprietary software, is not supported by the Ubuntu community, and is not available from the official Ubuntu repositories. It is located in the non-free section of third-party repositories which the user must specifically enable.

Which lead us to the possibility of the installation (alternatively, of course), of the Real Media Player for Linux, which seems to be discontinued but you can find older versions in the "Helix and RealPlayer Archive"

However, the installation of the sole codec should do the trick. I suggest you to try the restricted extras in first instance and to try again the .rm playback using your favorite media player.

Good luck!

share|improve this answer

MPlayer plays most MPEG, VOB, AVI, Ogg/OGM, VIVO, ASF/WMA/WMV, QT/MOV/MP4, FLI, RM, NuppelVideo, yuv4mpeg, FILM, RoQ, PVA files, supported by many native, XAnim, RealPlayer, and Win32 DLL codecs. It can also play VideoCD, SVCD, DVD, 3ivx, RealMedia, and DivX movies.

SMPlayer (GUI for MPlayer)

share|improve this answer
ubuntu-restricted-extras is a bit stupid. It even downloads some microsoft fonts and ask me to agree to their eula which i will never do. Need a better option – Jaseem Sep 11 '11 at 20:42
The additional page mentioned is tooooo outdated – Jaseem Sep 11 '11 at 20:43

Ubuntu restricted (install as said above or in Synaptic or Ubuntu Software Center) is a must as far as I am concerned. Many other problems may be solved this way. It worked for me and didn't have to agree to anything like eula etc. Nothing wrong having the microsoft fonts. As far as a better option is concerned, a "better" one has to be a possible one. This one works. SMPLAYER is a must too. Anyway, the fact that VLC didn't do the trick in the fist place might point to a special problem with the file.

But finally you might want to try Real Player for linux (here)

share|improve this answer
Answer or comment? – Tachyons Feb 20 '12 at 14:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.