Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently apt-get remove'd xscreensaver and apt-get install'd gnome-screensaver. This appears not to have worked because when I press the Lock Screen menu item, nothing happens. I have tried putting gnome-screensaver in the list of autostart applications but this doesn't help (must it be started before anyone logs in?). How can I make gnome-screensaver work properly and make the Lock Screen button do what it's supposed to? Thanks in advance, ell.

EDIT: I am using Xubuntu 11.04 and the output of ps aux | grep saver is:

elliot    1374  0.0  0.3  27344  6024 ?        Ss   19:35   0:00 gnome-screensaver
elliot    1669  0.0  0.0   4160   848 pts/0    S+   19:48   0:00 grep --color=auto saver

But I think the above information will now be irrelevant as it seems that locking the screen now works, when I lock the screen I get a black screen and when I move the mouse, the unlock dialog pops up so now all I need to do is set a screensaver, can anyone help me out on that?

share|improve this question

2 Answers 2

up vote 5 down vote accepted

Installing

When you have removed xscreensaver and installed gnome-screensaver you will need to logout and login for the XFCE lock-screen menu item to work

Setting your screen saver

Installing gnome-screensaver also installs gnome-screensaver-preferences.

If you run this in a terminal you will see this screen which will allow you to change from the "black screen" to one of the gnome-screensavers:

enter image description here

Integrating with Settings Manager

When installing gnome-screensaver it will create a file called /usr/share/applications/gnome-screensaver-preferences.desktop

To integrate this into Settings Manager then replace the contents of this file with the following:

[Desktop Entry]
Name=Screensaver
Comment=Set your screensaver preferences
Icon=preferences-desktop-screensaver
Exec=gnome-screensaver-preferences
Terminal=false
Type=Application
Categories=Settings;DesktopSettings;Security;X-XFCE
NotShowIn=KDE;GNOME;
share|improve this answer
1  
Unfortunately, gnome-screensaver-preferences is no longer shipped along with 12.04 (and up). So how does configuration take place now? I'm not that much concerned about fancy stuff, but e.g. configuring screen timeout. –  Izzy Jun 10 '13 at 6:32
    
    
Thanks! The second one I definitly missed (no screensaver tag :) Will check them both. Still, I cannot understand why there's no user-friendly solution (or rather why that was removed)... –  Izzy Jun 10 '13 at 7:45

You don't need to remove Xscreensaver. After you install gnome-screensaver, you can change the file /usr/bin/xflock4 to give priority to grome-screensaver.

Install gnome-screensaver:

sudo apt-get install gnome-screensaver

Open file:

sudo nano /usr/bin/xflock4

Find

# Lock by xscreensaver or gnome-screensaver, if a respective daemon is running
for lock_cmd in \
"xscreensaver-command -lock" \
"gnome-screensaver-command --lock"

Replace

for lock_cmd in \
"gnome-screensaver-command --lock" \
"xscreensaver-command -lock"

May need logging out and in again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.