Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I liked the shortcut for opening a terminal and if I remember correctly it was Ctrl-Alt-t that opened a terminal window.

Now with a later version of Ubuntu this shortcut is no longer predefined, I must add it myself from the shortcut settings.

Do you know why this shortcut was removed?

Thanks for any answer enter image description here

$ uname -a
Linux ubuntu 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
share|improve this question

4 Answers 4

up vote 6 down vote accepted
+100

The shortcut is still there for what I know.

There is perhaps some other application hiding that shortcut?

share|improve this answer

Ctrl+Alt+T is not assigned by default as a shortcut key in Natty Narwhal. You can assign it manually to open the Terminal though by using the "Keyboard Shortcuts" application.

share|improve this answer
    
It is Live CD. I also have 10.04 that I can boot to and see if the difference really depends on the version or something else. I updated the question with a screenshot. Rebooting from Live CD of Natty has a disabled shortcut for running a terminal. Hm...Thanks for answering and please comment more what you think the reason is my Live boot does this. –  Niklas Rtz Sep 1 '11 at 14:41
1  
This is a conundrum :) All I can say is that this is not the first time something works one way on someone's box and another way on another person's box. I have see this before with numerous issues (e.g., whether video thumbnails preview or not). If you tap Super and type "ter" Terminal will come up in Dash at which point hitting enter will launch it. Perhaps developers considered this a simpler keyboard shortcut? And they figured for old school users they can always manually create Ctrl+Alt+T if they so desire? If I learn anything specific I'll report back ;) –  Chad--24216 Sep 1 '11 at 15:30
1  
Ctrl+Alt+T is assigned by default to launch Terminal in Oneiric. For Natty you will have to add the shortcut manually. –  Chad--24216 Sep 2 '11 at 16:27

Ctrl+Alt+T does not work by default in all desktop environments for example in Xubuntu it is super + t

share|improve this answer
    
not true. Lubuntu 14.04 always works –  user251046 Feb 23 at 14:29
    
ok that does not negate my statement, though it is good to post that info in case someone was looking into this and wanted to know. –  CrandellWS Feb 24 at 17:36

For 14.04 release, (for Unity) unity-settings-daemon or exactly its media-keys plugin handles terminal launcher shortcut.

$ dconf read /org/gnome/settings-daemon/plugins/media-keys/terminal
'<Primary><Alt>t'

System Settings → Keyboard → Shortcuts → Launch Terminal

enter image description here

(for Gnome) gnome-settings-daemon same as its fork unity-settings-daemon. Otherway using Compiz, it has a setting in Gnome Compatibility plugin:

ccsm → Gnome Compatibility → Commands → Open a terminal

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.