Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The login screen shows and i choose myself. Then the screen goes black, and the login screen shows again.

share|improve this question
This would be the kind of question where knowing what preceded your problem may lead to the answer. Did you install new packages? Did you mess with GDM configuration? Is this a new install, or were you able to get it working before? – emf Oct 13 '10 at 5:51
The thing that preceded my problem is that i upgraded 10.04 to 10.10. I didn't mess with gdm configuration. – Arvid Oct 13 '10 at 19:29
Even though this is an old thread, if anyone is having this problem and looking for a answer, see the link below where the same question was answered well with an easy fix.… – user151976 Apr 25 '13 at 7:55

No answer, but this may be related to one of these two bugs:

Login Loop problem with 10.10

or Hitting send at login seems to restart X

I had a problem with GDM restarting (once) each time when trying to log in after upgrading to Maverick Alpha, upon installing GDM on top of an existing ubuntu Server install.

The solution for me was to remove GDM and GDM configuration files and reinstall.

ONLY RECOMMENDED if you can't get another solution.

share|improve this answer

I just had this exact problem with Linux Mint 10 Julia, which is based on Ubuntu. Login to tty1 console works, but not the graphical login (login loop as OP described).

The problem was in the /etc/profile file.

#... stuff   
if [ "$PS1" ]; then
  #... more stuff

. /path/to/file/that/does/not/exist #raises an error and interrupts the login

umask 022

Once I removed the ". /path/to/file/that/does/not/exist" line, the login loop would stop and I could login to my desktop again.

So, make sure your .bashrc, .profile, /etc/profile files etc are clean and don't raise any errors that interrupt the flow.

share|improve this answer
This was my problem--although it wasn't a missing file, I think it might have been a function definition (which worked when I would load it via . .profile, not sure why it broke things at startup). – weberc2 Jan 11 '15 at 21:11

Possible problem might have been that the /tmp directory has been removed or its permissions changed.

  1. Press Ctrl-Alt-F1 and go to the terminal.
  2. Create the directory by mkdir /tmp.
  3. Change the permissions by chmod 777 /tmp
  4. Ctrl-Alt-F7 and come back to the login screen and login.
share|improve this answer

A common source for this problem is a full harddisk. Try switching to a Terminal (CTRL+ALT+F1) and log in. Now run

sudo apt-get clean && sudo apt-get autoclean

which should give you some space. Now log out and go back to the graphical login-screen (CTRL+ALT+F7 or F8 or F9) and try again.

share|improve this answer
It says E: Invalid operation auto-clean When i run df it says i have 9G free disk space. – Arvid Oct 11 '10 at 19:47
The correct command is 'autoclean', not 'auto-clean'. Also, some part of the disk (a % relative to total partition size) is reserved for the root user, which might well be 9 GB on a large disk. – JanC Oct 12 '10 at 2:50
I've managed to login by choosing safe mode from grub, then choosing root prompt, typing the root password, and running startx. – Arvid Oct 12 '10 at 15:42
If i type "login" and login as myself after entering the root password, and then run startx, it results in a black screen. If i try to login as root at the gnome login screen, it bounces back just as when i login as myself. – Arvid Oct 12 '10 at 15:49

If you have a livecd, can you run a disk check (from the command line) on the disk? I've had systems do this before because of bad permissions, and a simple disk check fixed the problem.

share|improve this answer

Autologin worked fine for me, but not afterwards. I fixed it thanks to

sudo dpkg-reconfigure -phigh xserver-xorg

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.