Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm working on a desktop machine with plenty of screen real-estate, so I don't need my windows' title bars to merge with the global menu bar when the windows are maximised. Moreover, I'm working on a dual-screen set-up, so the fact that a window is maximised doesn't mean that it's the only window visible.

Before Unity I'd switch to a maximised window by clicking on its title bar, or close the window, even though it isn't focused, by clicking on its close button; I can no longer do this because the title bar is missing and the global menu bar is empty on that screen. This isn't a huge problem - I can click on some of the window's chrome to focus it - but it's unintuitive and it's forcing me to relearn my mousing behaviour.

I'd like to turn-off the merging of title and global menu bars, but how?

EDIT:

I simply want the title bar of the window NOT to merge with the top panel whenever I maximize a Window. The global menu should stay in the top panel as far as I am concerned. Current it maximizes like this

enter image description here

I want it to maximize like this (In that screeny the unmaximized Window has been resized to take rest of the space)

enter image description here

share|improve this question
    
Is using the classic Gnome 2 desktop not a better option perhaps? –  Benjamin Sep 1 '11 at 9:38
6  
No, Classic GNOME 2 isn't a better option. Lots of stuff in Unity isn't bad, but with a multi-monitor set-up it's useful to be able to click on a window's title bar to focus it, even if that window is maximised. Unity's merge-the-title-bar-into-the-panel behaviour prevents one from being able to do that. That's not a reason to throw the baby out with the bath water though. –  Richard Turner Nov 3 '11 at 10:49
    
It can be done using a custom session, but it won't work as you hoped because the global menu is only visible during mouseover afiak, like your second screenshot shows. You'll just end up with 2 copies of the title bar. –  Veazer Apr 18 '12 at 23:16
    
@Veazer Well, that's a start; at least then the remaining problem is just how to patch the global menu to be displayed all the time instead of only on mouse-over. Care to submit an Answer explaining how to achieve this using a custom session? –  Richard Turner May 29 '12 at 9:30
    
Are you using Unity 3D or 2D? If 2D, would you want metacity or compiz for the window manager? –  Veazer May 30 '12 at 10:45

6 Answers 6

up vote 2 down vote accepted

ctrl + alt 5 seems to be your best bet as of right now. Sorry. Perhaps to remove temptation you could remove the maximize button in Ubuntu-Tweak but as of right now if you maximize the window, it simply will merge the titlebar with the menubar

share|improve this answer
1  
Any update on this? –  AlexP May 24 '13 at 17:53
    
ctrl+alt+5 does nothing here, but ctrl+alt+numpad5 just maximizes and the titlebar still merges :( –  Aquarius Power Oct 24 '13 at 2:47
    
@AlexP I wrote a script below that may help you too :) –  Aquarius Power Oct 24 '13 at 17:06

You can disable window maximize to title bar when a titlebar is dragged near to the Unity Top/Superior bar.

Visit: http://ubuntuforums.org/showthread.php?t=1743309 ( Note post #6 by stevecomrie )

  • Open CompizConfig Settings Manager
  • Click on the "Grid" in the "Window Management" category
  • Click on the "Edges" tab
  • Open the "Resize Actions" drop down
  • Change the "Top Edge" drop down to "None"
  • Close CompizConfig and you're all done.

This is only a partial solution. Some applications will still launch themselves into the merged state when you run them. And, you can still inadvertantly cause a merge by double-clicking on the title bar of an an unmerged application. Anybody with a clue as to how to completely disable any and all variations of unity panel merging with an application's title bar would be appreciated!

share|improve this answer
    
This solution can also be used to disable the left/right edge behaviour as well. –  ImaginaryRobots Mar 30 '12 at 20:46

As far as I understand, this is not yet possible (there is some talk of bringing it to Ubuntu 12.04 or 12.10, but we will have to wait and see). A possible solution in the here and now is using Emerald as the window decorator, but I don't know if that will work 100%.

share|improve this answer

Source: http://ubuntuguide.net/unity-2d-how-to-removeenable-maximized-window-titlebar

This can be handled by gconftool. If you have the GUI frontend "gconf-edtor" installed, just launch it and navigate to /apps/metacity/general, then un-check “show_maximized_titlebars” to remove the maximized window titlebar.


Or, you can execute this command in terminal to remove it:

gconftool --type bool --set /apps/metacity/general/show_maximized_titlebars false

Run this to re-enable it:

gconftool --type bool --set /apps/metacity/general/show_maximized_titlebars true
share|improve this answer
1  
I hadn't used Unity for a long time since I posted this question, so I've been unable to test people's responses. I had high hopes for your answer, but in full-blown Unity on Ubuntu 12.10 it doesn't work. Perhaps it only ever worked for Unity 2D.... –  Richard Turner Mar 22 '13 at 18:30
    
Yes, this only works for Unity 2D. Notice apps/metacity. Unity 3D uses Compiz, Unity 2D uses Metacity. –  Seth May 17 '13 at 17:02

For Unity 3D, you can try this script.

Basically it will check for maximized windows and will demaximize them and resize them to the max width height possible (that after you make tests you find it to be working well on your machine); play also with nXpos and nYpos if you feel something is not working fine.

demaximize.sh 1005 710 #for 1024x768 that works here at least...

#!/bin/bash

# make tests to your system, this works 'here' at 1024x768
nWidth=$1 #1005
nHeight=$2 #710
nXpos=1
nYpos=22

while true; do 
    windowId=`xdotool getactivewindow`;
    if xwininfo -wm -id $windowId |tr -d '\n' |grep -q "Maximized Vert.*Horz";then
        wmctrl -i -r $windowId -b toggle,maximized_vert,maximized_horz;
        xdotool windowsize $windowId $nWidth $nHeight;
        xdotool windowmove $windowId $nXpos $nYpos;
        xdotool getwindowname $windowId
    fi; 
    sleep 0.5;
done

PS.: for chrome/chromium work better, enable "use system title and borders" option

share|improve this answer
    
A novel approach, but really this is a terrible hack isn't it? :) –  Richard Turner Jan 8 at 9:18
    
...that works and can be improved to work even better :), my current implementation has 220 lines of code :D, but it is indeed a terrible hack... I am forced to fix window placement "bugs?" of the window manager and many other strange things that would not be necessary if there was a window manager option to not maximize and just make the window have the maximum size possible; So that it would just be pseudo-maximized... –  Aquarius Power Jan 8 at 20:00

I nearly started crying trying to get rid of the global menu on Ubuntu 13.10. You see my main apps, e.g. Eclipse and Android Studio, sometimes "fail" when merging. You end up having a merged menu that only expands partially meaning you can't use the program any more. So I found this reference:

HOW TO REMOVE THE GLOBAL MENU BAR ON UBUNTU 13.10

$ sudo apt-get remove indicator-appmenu

I had to reboot as well and now life is much better.

share|improve this answer
    
I'm glad life is better for you having found a solution to your problem, but this bears no relation to the question asked, which is about window titlebars, not about the global menu. –  Richard Turner Jan 8 at 9:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.