Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had a problem for quite some time now. When I boot up my Ubuntu 11.04 it just won't load X. It works when I first load in failsafe mode and then restart X, however this is a quite annoying procedure to go through every time I start my computer.

What I've found in my Xorg.1.log that looks suspicious is this:

Using config file: "/etc/X11/"

In the Xorg.failsafe.log it says

Using config file: "/etc/X11/xorg.conf.failsafe"

which to me makes more sense.

Here is my Xorg.1.log http://pastebin.com/AfF50sji and here is the xorg.conf file found in /etc/X11/xorg.conf http://pastebin.com/Gy2ANKwD

Everything works fine after failsafe start and X restart, but the computer just won't start in a normal way.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I would have expected the log Xorg.0.log to be used for trouble-shooting.

Here is a suggestion. Try moving to one-side the xorg.conf file and rebooting.

Then rerun nvidia-settings.

i.e.

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

reboot, then

gksudo nvidia-settings

Edit:

It is also worth ensuring that nvidia is installed corrected. Go to your Additional Drivers window and deactivate the nvidia driver. Then purge any remaining nvidia software installed i.e.

sudo apt-get purge nvidia*

Double check you haven't added anything to your grub boot options that deals with graphics e.g. nomodeset, vga= etc etc. If you have - remove them and do an sudo update-grub

If you have previously blacklisted nouveau then unblacklist it. Reboot. You should be running with the default opensource drivers.

After rebooting - reinstall the Additional Drivers "nvidia-current" driver. Rerun nvidia-settings as described previously.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.