Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Keyboard sticks randomly

My laptop keyboard has gone crazy. When I type something on it, it's like I hammered the keys. Example: hello myyyyyyyyyyyyyyyyyy name is gardar how are yoooooooooooooooooou?

This is more likely to happen when I type fast keyboard but also happens when I type real slowly.

Ubuntu 10.04 is my main OS along with OSE Virtualbox Win XP

This can't get anymore annoying and it's taking me about forever to post this message.

share|improve this question

marked as duplicate by fossfreedom, dv3500ea, desgua, Jorge Castro, Marco Ceppi Sep 1 '11 at 2:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
what do you mean, fossfreedom? I have turned internet upside down and not solution so far... –  Natalstone Aug 31 '11 at 10:55
    
I've just linked you to a similar question - though no solution in that question yet. –  fossfreedom Aug 31 '11 at 11:05
    
I SEE< YES< THE PROBLEM IS SIMILAR –  Natalstone Aug 31 '11 at 11:18
add comment

1 Answer 1

Since there are now two related posts on this I'm guessing it's a bug. A simple workaround would be to turn off repeated key presses.

  1. Click the icon at the very right of the top panel and select System Settings.
  2. In the Hardware section, click Keyboard.
  3. On the General tab, turn off Key presses repeat when key is held down to disable repeated keys entirely. Alternatively, adjust the Delay slider to control how long you have to hold a key down to begin repeating it, and adjust the Speed slider to control how quickly key presses repeat.

(via Official Ubuntu Help Documentation.)

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.