Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to dual boot Ubuntu and fedora, but now I am unable to boot into my Ubuntu installation. Here is the situation I had Ubuntu installed already on /dev/sda2 and I resized it to create another partition /dev/sda3 . I installed fedora 15 on /dev/sda3 . Now I can boot into fedora but there in to option to go into Ubuntu. Swap partition is on /dev/sda1.

Swap /dev/sda1
Ubuntu /dev/sda2
Fedora /dev/sda3 
share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

Fedora 15 still uses grub legacy for boot, and it overwrites Ubuntu's Grub 2 boot loader and menu. And Grub legacy does not find Ubuntu install out-of-the-box.

To restore Ubuntu's boot, all you have to do is re-install grub2.

Do this:

  • Boot using Ubuntu's Live CD
  • Open Nautilus, and double-click Ubuntu's partition. Take note of its mount point directory (if you labeled the partitions, it will be something like /media/label
  • Now open terminal and issue:

    sudo grub-install --root-directory=/media/your-ubuntu-label /dev/sda

  • You may boot into Ubuntu now.

  • If you want to add Fedora 15 to Ubuntu's (grub2) boot list, do this:

    sudo update-grub

share|improve this answer
    
Thanks Man, that solved my problem :) –  Harbhag Sep 1 '11 at 15:14
    
This procedure does not work anymore on Ubuntu 13.04 with Fedora 19. Any ideas? –  Ciro Santilli Jul 6 '13 at 14:17
    
Take back my comment, this might have worked, but I had installed fedora on top of an existing partition, and fsck kept trying to mount that because of my fstab. –  Ciro Santilli Jul 6 '13 at 15:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.