Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying to install some 32bit libraries with dpkg -i --force-architecture command. But it failed due to dependency problem.

Now if I try to install 64 bit version of the same library, it says it is already installed. If I try to remove it it says its not installed.

dpkg-query -l shows that the status is rU for the package.

I tried dpkg-configure -a, dpkg--reconfigure, apt-get install -f, apt-get clean, apt-get autoclean and basically every possible Google search.

How can I get out of this stuck package installation?

share|improve this question
    
Does sudo dpkg --configure -a say anything? What's the full name of the package? –  arrange Aug 30 '11 at 17:11
    
No, it doesn't say anything. libgtk1.2 is the full name of the package. –  Animesh Aug 30 '11 at 17:30
    
Can you post the full output of sudo dpkg -r libgtk1.2? –  arrange Aug 30 '11 at 17:35
    
dpkg: warning: there's no installed package matching libgtk1.2 Processing triggers for python-central ... –  Animesh Aug 30 '11 at 17:46
    
And the output of the attempt to install the 64bit version? And do you have any related files in /var/lib/dpkg/info/? (ls -l /var/lib/dpkg/info/libgtk*) –  arrange Aug 30 '11 at 17:55
show 2 more comments

1 Answer

up vote 1 down vote accepted

Multi-arch packages should be suffixed with :arch where arch is i386 or amd64. Try the i386 version of libgtk1.2 by explicitly naming it:

sudo apt-get purge libgtk1.2:i386

If this fails due to dependency issues, try adding the -f option.

Where did you get these libraries from? The current GTK+ library is at 2.24-4 for Natty (libgtk2.0-0). libgtk1.2 can be found in Hardy and Dapper according to packages.ubuntu.com.

share|improve this answer
    
The output is: E: Unable to locate package libgtk1.2:i386 E: Couldn't find any package by regex 'libgtk1.2' I installed it from packages.Ubuntu.com as needed by Unreal tournament 2004 game. –  Animesh Aug 31 '11 at 1:51
    
This one worked: sudo dpkg -r libgtk1.2:i386 –  Animesh Aug 31 '11 at 1:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.