Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 11.04 and have installed sun-java6-* packages.

My workstation is running behind an authenticated proxy, I've set the gnome proxy settings system wide and almost everything works fine, except for the Java applets that ask me for the proxy password but doesn't work when I type in.

Any ideas about how to make it work?

share|improve this question

2 Answers 2

Maybe you should set your proxy settings in /etc/environment and re-login. Use this format: http_proxy='http://username:password@domain:port/'. If it didn't work, use CNTLM to login to your proxy server instead. You can easily install it using Ubuntu software center or Synaptic Package Manager.

share|improve this answer
    
the first way doesn't work.. and using CNTLM I didn't figure out how to use it. I appreciate if you can help me with that. –  Lucas Vasconcelos Sep 2 '11 at 14:33

I know this is an old post, but perhaps explicitly changing the setting in the Java control panel might help:

  • Open the Java Control Panel by running the command javaws -viewer

  • In Control Panel: General > Network Settings

Then try changing proxy settings.

share|improve this answer
    
The command opens the "Trusted certificate viewer" program for me (openjdk-6-jre). Does the command work different with Oracle Java? –  Lekensteyn Feb 16 '12 at 17:25
    
@Lekensteyn; Java Control Panel is only available for Sun/Oracle JDK --you will have to migrate to Oracle JDK if you want to use it. However, when you install Icedtea plugin, javaws will use your browser proxy details. –  phiri Feb 17 '12 at 20:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.