Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How can I install a .bin file?

I have a .bin file called file.bin and I am new to ubuntu and I am trying to figure out how to install it.

What is the proper command to run via Terminal?

I have tried:

./file.bin - reports error "Directory does not exist"

and

sudo ./file.bin - nothing happens at all with this command.

How do I execute this binary?

share|improve this question

migrated from stackoverflow.com Aug 29 '11 at 23:17

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Jorge Castro, Marco Ceppi Aug 30 '11 at 0:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Make sure you are in the same directory as the file, when you type "ls", does "file.bin" show up? –  habitmelon Aug 29 '11 at 22:59
    
It's not called "file", it's called "file.bin"; the suffix is part of the file name. Where did you get it? It's likely that ./file.bin is the correct way to install it, but a file whose name ends in .bin could be anything. –  Keith Thompson Aug 29 '11 at 23:01
    
Yes it does. screensnapr.com/v/JJ4bZA.png –  Duncan Palmer Aug 29 '11 at 23:01
    
Given the screenshot, I would guess that install.sh is the file you want to run, not file.bin. –  frabjous Aug 29 '11 at 23:34
    
It was probably complaining that it couldn't execute the command named on the #! line at the top of file.bin. But from the looks of your screen snapshot, I suspect you should be running install.sh, not file.bin (install.sh probably takes care of invoking file.bin in the appropriate manner). What did the installation instructions tell you? –  Keith Thompson Aug 29 '11 at 23:37

1 Answer 1

Go to the directory where you have your file (say file.bin) and ensure the permissions will allow you to run it:

chmod u+x file.bin

Then run it with either of:

./file.bin
sudo ./file.bin

You may alternatively have to use something like:

bash file.bin

You should refer to the installation istructions. If they're good, they will tell you exactly what you should do. If not, I'd be circumspect about the software since the developers aren't as good as they think they are :-)

share|improve this answer
    
screensnapr.com/v/lw1add.png Still comes up with the same –  Duncan Palmer Aug 29 '11 at 23:02
    
I have followed the instructions, and when i use bash command it says "Cannot execute binary file" and the software is hldsupdatetool from valve software. –  Duncan Palmer Aug 29 '11 at 23:04
1  
Don't worry problem solved, was missing lib32gcc1. –  Duncan Palmer Aug 29 '11 at 23:07