Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just solved a problem by installing the latest ATI Drivers from AMD's website. Problem is I think it crashes my system, like few times a day already ... How can I confirm its the cause and how can I fix it?

UPDATE

I am using

  • ATI Radeon 5670
  • Ubuntu 11.04 Desktop
  • 2.6.38-11-generic

I reverted back to the driver from Jockey/Additional Drivers. So no crashes, I will probably use the ATI/AMD sites 1 again to see if it crashes, then post the log.

UPDATE

I just rebooted from a crash, this time, I am using Open Source drivers.

Last "few" lines of Xorg.0.log on pastie

Same for syslog

Maybe its not a graphics or driver thing? Can it be something else? How can I troubleshoot?

UPDATE 2

It might also be Unity? I installed a "bare" Ubuntu 11.04 system via Alternate CD then install the packages. While using Ubuntu Classic, all seemed well. Then I switched to Unity, it appeared not to work with the defuault dirivers then things start going wrong ... also see below ... Whats with the super dark shadows and artifacts with the launcher?

share|improve this question
    
Please add details of your graphics card, the driver you have installed and what version of Ubuntu you are using. If you are using a different kernel from standard - that would be useful information. Also - look at /var/log/Xorg.0.log for any X problems. –  fossfreedom Aug 29 '11 at 19:11
    
@fossfreedom, See update, I will post the log when I revert back to the AMD driver and/or it crashes, after my homework –  Jiew Meng Aug 30 '11 at 2:48
    
Isn't the driver jockey gives you the SAME proprietary AMD driver? just an older version?. –  Uri Herrera Aug 30 '11 at 3:13
    
Perhaps, maybe the newer version got some bug that keeps crashing my system? The one from jockey doesnt use the entire screen –  Jiew Meng Aug 30 '11 at 5:13
    
@jiewmeng that's not the fault of the driver, in most cases is something else, for example i do suffer from that question you linked, i'm using an hdmi cable and the overscan doesn't fill the screen, nor the correct resolution is available, on Windows i get the correct resolution. This didn't happen when i was using a VGA cable. –  Uri Herrera Aug 30 '11 at 6:47

3 Answers 3

up vote 0 down vote accepted
+100

yes, the proprietary drivers are very bad. Actually, they've been responsible for 100% of freezes I've experienced on Ubuntu for the last two years since I got my Radeon HD5850. But luckily, the open drivers are now very good. They are much faster than the proprietary drivers, very much more stable and they seem to provide a similar set of features. Since they're open, you also don't need to update them manually anymore.

In 11.04, I have had a few minor draw issues with it in Unity, but except for that, it's been very good and stable. In 11.10, which goes into Beta 1 tomorrow, I haven't had a single issue. I've been told that AMD now has people working full time on the open driver. I haven't been able to verify that, but the rapid progress they've suddenly made, makes that seem probable. It's a very good thing if it's true, because they make really good hardware, and it's been very annoying that they've had so poor drivers. The bonus for us users of Ubuntu, is that it makes new releases of Ubuntu feel extra fast and good :)

By the kernel, you seem to be running 11.04 and I would strongly recommend that you try using xserver-xorg-video-radeon instead of the proprietary drivers. The issues I've had are very small. Some white dots on the dash is all. This is based on my experiences with the Radeon HD5850, of course, but I've been told that other cards in the 5-series, as well as newer cards also work very well. I'd appreciate it if you leave a comment with your experiences. I'll also add the 11.04 tag to your question to make it easier for others to find your question.

Update: no doubt, Unity will provoke more driver problems than Ubuntu Classic, since it makes much heavier use on Compiz. I personally could never get the proprietary drivers to work well with Unity. The open drivers also caused some issues, but they were minor compared to the ones caused by the proprietary drivers. I've never had crashes like you've had though. I've had to re-run compiz in order to fix minor issues, but nothing worse than that. But we don't have exactly the same hardware, so... What I can say, is that it's improving and that in Oneiric, I have no issues at all. So, all in all, it seems to me that AMD is making large improvements in this area.

share|improve this answer
    
Can Unity even run with those open source drivers? –  Jiew Meng Aug 30 '11 at 6:52
    
UPDATE: Oh yes it actually can, I thought it can't ... must be missing some package last time? any ideas? –  Jiew Meng Aug 30 '11 at 6:57
1  
The drivers have improved rapidly. It works very well and in 11.10 it's completely flawless. I am a little puzzled that I would be downvoted for saying that the open drivers are now better than the proprietary ones. It's a very good thing that AMD is now doing this. –  Jo-Erlend Schinstad Aug 30 '11 at 7:26
    
Haha ... it appears you are right, I switched to proprietary as I thought the open source 1 didn't support Unity! It will be great to hear the downvoter's or ppl that disagree. Perhaps for games its lousier? But theres not much games in Linux is there? –  Jiew Meng Aug 30 '11 at 8:16
    
No, AMD is working actively on the open drivers in cooperation with the rest of the open source communities, so they should be better in all instances. Remember to deactivate Compiz before running games in Wine though. There are more and more games coming to Linux. –  Jo-Erlend Schinstad Aug 30 '11 at 22:13

It's a problem with proprietary drivers, sorry but u can't use them, instead, try the latest Xorg drivers, here is the ppa: https://edge.launchpad.net/~xorg-edgers/+archive/ppa

To install them do:

  1. sudo apt-add-repository ppa:xorg-edgers/ppa
  2. sudo apt-get update
  3. sudo apt-get upgrade
share|improve this answer
2  
Using this particular PPA should be used with extreme care - as the developers themselves say, its a testing PPA and can and does (frequently) break your install! Only use it if you know how to recover from black-screens etc. –  fossfreedom Sep 7 '11 at 20:48

The ATI drivers are awfull, you might try the free drivers. Two years ago the close-source driver was better (well... less bad) but by now the mesa drivers are really improved.

Also, you should try the free drivers from xorg-edgers, they're experimental but more stable than the amd's.

share|improve this answer
    
I've had no problem with the ATI drivers on my old system with a newer Radeon 6770 card. My old nvidia card was blacklisted from running Unity, so I'm happy. –  belacq Sep 8 '11 at 20:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.