Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I configure a Chinese input method for KDE? I don't want a Chinese locale, just to write Chinese characters, mainly for learning purposes. (I'm still learning the language, so switching the entire UI to Chinese is not an option...)

Google search results are inconclusive, and from what I understood, not specific to newer versions of KDE.

Details: Kubuntu 11.04, KDE 4.6

share|improve this question
add comment

2 Answers 2

Install the package iBus from the kubuntu repository, info here: http://code.google.com/p/ibus/. This is just an input method and doesn't change your system settings.

  • for pinyin input install ibus-pinyin
  • for handwriting recognition install ibus-tegaki
  • the fonts are available from the package language-pack-kde-zh-hans

Afterwards go to your system preferences and change input method to iBus.

If you are learning, I would suggest two more programs you might already know:

Anki (for learning flashcards)

In Anki you can use a very helpful plugin called pinyin-toolkit (http://ankisrs.net)

Eclectus (an offline dictionary)

Eclectus can use tegaki for handwriting input as well. You can install audiopack (made from swac collections) and strokeorder-fonts. You need to install the marcspitz/eclectus PPA for those packages. The original Eclectus (as well on launchpad) doesn't work on 11.4.

Enjoy learning!
Marcus

share|improve this answer
    
Thanks! However, ibus appears to be installed on my system (from the distro repo), and even seems running, but I don't find where to control it. There's no input method icon, and in the system settings there is no entry for input method –  Little Bobby Tables Aug 29 '11 at 14:36
add comment

You may want to take a look here: http://code.google.com/p/ibus/wiki

I had exactly same problem as Yours but thanks to Your post and webmarwells reply I have found solution :)

Was missing also the trigger to actually start input of pinyin.

So after playing with ibus-setup etc, I did:

 sudo apt-get update 
 sudo apt-get install ibus-gtk ibus-qt4 ibus-pinyin ibus-pinyin-db-open-phrase  

I have also installed packages for ibus-chewing - as I noticed the name of chapter on ibus site

then

 im-switch -s ibus

Logout and re-login

works like a charm :) good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.