Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running:

  • Lubuntu 10.10
  • MPlayer 2:1.0~rc4~try1.dsfg1-1ubuntu1+medibuntu1
  • w32codecs 1:20110131-0.1medibuntu3

While trying to play a streaming rtsp clip with mplayer, I get an error message saying: Cannot find codec for audio format 0x55.

According to here, audio format 0x55 is "MPEG-1 Layer 3 (MP3)", and should be supported by l3codeca.acm. I do have l3codeca.acm in /usr/lib/codecs. However, when mplayer tries to load this codec, it says (see full log below):

Opening audio decoder: [acm] Win32/ACM decoders
Loading codec DLL: 'l3codeca.acm'
Loaded DLL driver l3codeca.acm at 212d000
ACM_Decoder: Unappropriate audio format
Could not load/initialize Win32/ACM audio codec (missing DLL file?).

It looks like this guy has the same issue, but he is playing a local file.

According to mplayer's Codec Status Table, this codec "conflicts with security kernel patches", but I'm not sure what that means.

Any ideas? I don't specifically need this to work in mplayer, I just want to be able to play it. However, vlc and openRTMP didn't work for me either (although I may not have been using openRTMP correctly).

Here's all the information mplayer spits out:

$ mplayer  rtsp://rs2.SichosInEnglish.org:554/sie/heritage/01.mp3
MPlayer 1.0rc4-4.4.5 (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing rtsp://rs2.SichosInEnglish.org:554/sie/heritage/01.mp3. Resolving rs2.SichosInEnglish.org for AF_INET6... Couldn't resolve name for AF_INET6: rs2.SichosInEnglish.org Resolving rs2.SichosInEnglish.org for AF_INET... Connecting to server rs2.SichosInEnglish.org[75.99.96.252]: 554... rtsp_session: session can not be established. STREAM_LIVE555, URL: rtsp://rs2.SichosInEnglish.org:554/sie/heritage/01.mp3 Stream not seekable! file format detected. Initiated "audio/X-MP3-DRAFT-00" RTP subsession on port 36274

========================================================================== Opening audio decoder: [mp3lib] MPEG layer-2, layer-3 ADecoder init failed :( ADecoder init failed :( Requested audio codec family [mpg123] (afm=mpg123) not available. Enable it at compilation. Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders Cannot find codec 'mp3float' in libavcodec... ADecoder init failed :( ADecoder init failed :( Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders Unknown/missing audio format -> no sound ADecoder init failed :( Requested audio codec family [mad] (afm=libmad) not available. Enable it at compilation. Opening audio decoder: [acm] Win32/ACM decoders Loading codec DLL: 'l3codeca.acm' Loaded DLL driver l3codeca.acm at 212d000 ACM_Decoder: Unappropriate audio format Could not load/initialize Win32/ACM audio codec (missing DLL file?). ADecoder preinit failed :( ADecoder init failed :( Opening audio decoder: [hwmpa] MPEG audio pass-through (fake decoder) Cannot sync MPA frame: 0 ADecoder init failed :( ADecoder init failed :( Cannot find codec for audio format 0x55. Audio: no sound Video: no video

Exiting... (End of file)`

share|improve this question
    
have a look here: mplayerhq.hu/DOCS/tech/win32-codec-howto.txt for more info. Looks like a protected mp3. –  Rinzwind Mar 4 '12 at 16:11
add comment

closed as too localized by Luis Alvarado, Ringtail, Takkat, fossfreedom Mar 31 '12 at 12:32

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.