Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When typing into terminal lspci, the output for the graphics card is VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18) BUT, further down there is VGA compatible controller: nVidia Corporation Device 0dd3 (rev a1)

Now i know i have an integrated graphics card, but the regular nvidia driver wont work properly, thus forced to use the Nouveau driver. And for some reason i suspect the Nouveau driver is giving me a hard time letting me connect to a large hdtv via hdmi. Help?

Ninja Edit: if i install the nvidia driver, it just says not in use, and it defaults me to gnome, so i cant use unity, while the Nouveau driver works perfectly..minus not working when i try to connect an external moniter

share|improve this question

2 Answers 2

It sounds like you've a Nvidia Optimus laptop. The nvidia driver from nvidia.com won't work with it out-of-the-box because of the way it's connected (through the CPU). See also How well do laptops with Nvidia Optimus work?

Since the nvidia driver cannot use the nvidia card and the Intel display is still used by the X server, OpenGL will be unavailable resulting in symptoms like:

  • Graphics effects / compositing do not work
  • Parts of the display turned upside-down
  • Unity ceases to work

To solve this issue after installing the nvidia driver, you need to set the GL library to Mesa which is used for the Intel card. Bumblebee does this when installing.

share|improve this answer
    
Thanks. Now as for the comment below, would it be ok if I installed BumbleBee first? Seems like i would have needed to edit config files, then install bumblebee from the instructions below –  user24037 Aug 28 '11 at 23:59
    
But anyho, I installed BumbleBee, with the edited .configs from below. But, it seems to output me to gnome still. But, the driver is finally in use. –  user24037 Aug 29 '11 at 0:51
    
The order you install bumblebee and nvidia does not matter. –  Lekensteyn Aug 29 '11 at 7:59

It seems you have hybrid graphics, which are not well supported (yet) under Linux. However, there is good news; you can disable Nouveau and install nVidia proprietary drivers somewhat easily. Lekensteyn has told you how enable the driver after installing; I'll tell you how to install it.

To do this:

  • Run gedit as root: gksu gedit (either run this in a terminal or in the run dialogue (alt+f2)).
  • Then open the following file: /etc/modprobe.d/blacklist.conf .

    • To this file add the following line:

    blacklist nouveau

  • Now open the following file: /etc/modprobe.d/nvidia-graphics-drivers.conf

    • Add these lines to the file

:

   blacklist nouveau  
   blacklist lbm-nouveau
   blacklist nvidia-173  
   blacklist nvidia-96  
   alias nvidia nvidia-current

Now install the nvidia-current driver using jockey-gtk (Additional Drivers in the menu), or from the command line as follows:

sudo apt-get install nvidia-current

After installing the driver, make sure to check the files you previously edited for changes, and ensure that the lines you needed to add are still present.
Now, restart your system, install Bumblebee as Lekenstyen suggested, and follow the instructions for Bumblebee to enable the driver.

share|improve this answer
    
Would it make a difference if I installed Bumblebee first? I just saw your comment, and i finished installing it –  user24037 Aug 28 '11 at 23:56
    
It shouldn't make a difference. I just suggested doing it in that order so you could get the most work out of the way first. –  RolandiXor Aug 29 '11 at 0:05
    
ok seems we have some success. The nvidia driver finally says its activated and in use, which is better than usual. But, it still defaults to gnome. I checked the .config files for both, and they are what they are supposed to be. –  user24037 Aug 29 '11 at 0:25
    
Also, when i go to the nvidia x server settings it gives me this error message, "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server." –  user24037 Aug 29 '11 at 1:19
    
@user24037: I forgot to add that to my answer. You need to run that command. –  RolandiXor Aug 29 '11 at 1:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.