Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

None of the global shortcuts work when I'm using any fullscreen game, including Alt+Tab.

I can't get out of the game until I use some kind of "exit" option, can't start/stop the music player...

This is especially annoying on my laptop, as fullscreen applications increase the brightness to the maximal value (which is another problem, but I think they have a common root), and I can't change it.

I use Kubuntu 11.10.

share|improve this question

closed as off topic by Bruno Pereira Feb 29 '12 at 22:02

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Are you still having the issue or have you resolved it after following the advice in the answers? – Mark Rooney Feb 24 '12 at 9:34
@MarkRooney: I never leave resolved questions without an accepted answer. Current answers just make things worse: the question isn't even listed in "unanswered". P.S. xorg tag isn't irrelevant. – Oleh Prypin Feb 24 '12 at 11:59
@BlaXpirit Maybe this would be better reported as a bug, would you not agree? Here are the instructions here, its easy and would help other users with the same issue. Ask Ubuntu handles only with questions that can answered and solved within the scope of the site. For more information on this please visit the FAQ. I will close this for now but if you have any issues with that please flag it back to the mods and explain the reasons why. Regards. – Bruno Pereira Feb 29 '12 at 22:01

It seems to me in a lot of games this simply does not seem to work, it really depends on the game. The only hotkeys that work always are the global hot keys for switching to terminal, like Ctrl+Alt+F1 etc., I think it must have to do with how the other hotkeys are handled in Ubuntu, at least with certain hardware, in some games I can not even change my volume with the funct key. However in games like Ryzom all the hotkeys work, and even the hot corners work for showing all windows and showing desktop etc.

share|improve this answer

A solution that works for me:

There is a plasmoid called Show desktop. I assigned Meta+D shortcut to it. Pressing Win+D minimizes all windows, though it doesn't change the screen resolution (at least immediately).

After you pause the music or respond to an IM message - maximize the game window again.

Though it is really pity no one implemented this in Kwin by default.

share|improve this answer
I have this Meta+D shortcut too, but it doesn't work in fullscreen games as well. – Oleh Prypin Sep 2 '11 at 10:55
Sorry, at least it minimizes Heroes Of Might and Magic III when full screen in Wine. – warvariuc Sep 2 '11 at 11:42
For Wine even hotkeys work – _ – Oleh Prypin Sep 2 '11 at 12:16
yes, Alt-Tab kind of works, but doesn't minimize the app, i.e. it switches the window and then makes the game fullscreen again. I hope Wayland will change things. – warvariuc Sep 2 '11 at 13:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.