Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Someday ago I tried the Marlin file browser (a nice crossover between thunar, nautilus and windows explorer) from elementary-dev PPA. Then I've encountered some troubles in updating packages. Playonlinux (that I sometimes use) stopped to work but other python apps seems to work (however I've problems at every system update).

edit: It seems the PPAs I've disabled in Synaptic are still present in ubuntu configuration. Restoring "official sources.list" can resolve my issues? Thanks in advance for your help :)

raffaele@Natty:~$ LANG=en_US;sudo apt-get update
[sudo] password for raffaele: 
Ign http://ubuntu.fastbull.org natty InRelease
Ign http://ubuntu.fastbull.org natty-security InRelease             
Ign http://security.ubuntu.com natty-security InRelease                        
Ign http://archive.canonical.com natty InRelease                               
Ign http://ubuntu.fastbull.org natty-updates InRelease               
Ign http://ubuntu.fastbull.org natty-proposed InRelease              
Ign http://ubuntu.fastbull.org natty-backports InRelease             
Hit http://ubuntu.fastbull.org natty Release.gpg                               
Ign http://extras.ubuntu.com natty InRelease                                   
Hit http://security.ubuntu.com natty-security Release.gpg                      
Hit http://ubuntu.fastbull.org natty-security Release.gpg            
Hit http://ubuntu.fastbull.org natty-updates Release.gpg                       
Hit http://ubuntu.fastbull.org natty-proposed Release.gpg                      
Hit http://archive.canonical.com natty Release.gpg                             
Get:1 http://extras.ubuntu.com natty Release.gpg [72 B]                        
Hit http://ubuntu.fastbull.org natty-backports Release.gpg                     
Hit http://security.ubuntu.com natty-security Release                          
Hit http://archive.canonical.com natty Release                                 
Hit http://ubuntu.fastbull.org natty Release                          
Hit http://ubuntu.fastbull.org natty-security Release                 
Hit http://ubuntu.fastbull.org natty-updates Release                  
Hit http://extras.ubuntu.com natty Release                            
Hit http://ubuntu.fastbull.org natty-proposed Release                 
Hit http://ubuntu.fastbull.org natty-backports Release                         
Hit http://security.ubuntu.com natty-security/universe amd64 Packages          
Hit http://archive.canonical.com natty/partner Sources                         
Hit http://ubuntu.fastbull.org natty/restricted Sources                        
Hit http://security.ubuntu.com natty-security/main amd64 Packages              
Hit http://security.ubuntu.com natty-security/multiverse amd64 Packages        
Hit http://security.ubuntu.com natty-security/restricted amd64 Packages        
Ign http://security.ubuntu.com natty-security/main TranslationIndex            
Ign http://security.ubuntu.com natty-security/multiverse TranslationIndex      
Hit http://archive.canonical.com natty/partner amd64 Packages                  
Ign http://archive.canonical.com natty/partner TranslationIndex                
Hit http://ubuntu.fastbull.org natty/main Sources                              
Hit http://ubuntu.fastbull.org natty/universe Sources                          
Hit http://extras.ubuntu.com natty/main Sources                                
Hit http://ubuntu.fastbull.org natty/multiverse Sources                        
Hit http://ubuntu.fastbull.org natty/main amd64 Packages             
Hit http://ubuntu.fastbull.org natty/universe amd64 Packages                   
Hit http://ubuntu.fastbull.org natty/restricted amd64 Packages                 
Hit http://ubuntu.fastbull.org natty/multiverse amd64 Packages                 
Ign http://ubuntu.fastbull.org natty/main TranslationIndex                     
Ign http://security.ubuntu.com natty-security/restricted TranslationIndex
Ign http://security.ubuntu.com natty-security/universe TranslationIndex
Ign http://ubuntu.fastbull.org natty/multiverse TranslationIndex               
Ign http://ubuntu.fastbull.org natty/restricted TranslationIndex               
Hit http://extras.ubuntu.com natty/main amd64 Packages               
Ign http://extras.ubuntu.com natty/main TranslationIndex                       
Ign http://ubuntu.fastbull.org natty/universe TranslationIndex                 
Hit http://ubuntu.fastbull.org natty-security/universe Sources       
Hit http://ubuntu.fastbull.org natty-security/main Sources                     
Hit http://ubuntu.fastbull.org natty-security/multiverse Sources               
Hit http://ubuntu.fastbull.org natty-security/restricted Sources               
Hit http://ubuntu.fastbull.org natty-updates/universe Sources                  
Hit http://ubuntu.fastbull.org natty-updates/main Sources                      
Hit http://ubuntu.fastbull.org natty-updates/multiverse Sources                
Hit http://ubuntu.fastbull.org natty-updates/restricted Sources                
Hit http://ubuntu.fastbull.org natty-updates/universe amd64 Packages           
Hit http://ubuntu.fastbull.org natty-updates/main amd64 Packages               
Hit http://ubuntu.fastbull.org natty-updates/multiverse amd64 Packages         
Hit http://ubuntu.fastbull.org natty-updates/restricted amd64 Packages         
Ign http://ubuntu.fastbull.org natty-updates/main TranslationIndex             
Ign http://ubuntu.fastbull.org natty-updates/multiverse TranslationIndex       
Ign http://ubuntu.fastbull.org natty-updates/restricted TranslationIndex       
Ign http://ubuntu.fastbull.org natty-updates/universe TranslationIndex         
Hit http://ubuntu.fastbull.org natty-proposed/universe Sources       
Hit http://ubuntu.fastbull.org natty-proposed/main Sources           
Hit http://ubuntu.fastbull.org natty-proposed/multiverse Sources     
Hit http://ubuntu.fastbull.org natty-proposed/restricted Sources               
Hit http://ubuntu.fastbull.org natty-proposed/universe amd64 Packages          
Hit http://ubuntu.fastbull.org natty-proposed/main amd64 Packages              
Hit http://ubuntu.fastbull.org natty-proposed/multiverse amd64 Packages        
Hit http://ubuntu.fastbull.org natty-proposed/restricted amd64 Packages        
Ign http://ubuntu.fastbull.org natty-proposed/main TranslationIndex            
Ign http://ubuntu.fastbull.org natty-proposed/multiverse TranslationIndex      
Ign http://ubuntu.fastbull.org natty-proposed/restricted TranslationIndex
Ign http://ubuntu.fastbull.org natty-proposed/universe TranslationIndex        
Hit http://ubuntu.fastbull.org natty-backports/universe Sources                
Hit http://ubuntu.fastbull.org natty-backports/main Sources                    
Hit http://ubuntu.fastbull.org natty-backports/multiverse Sources              
Hit http://ubuntu.fastbull.org natty-backports/restricted Sources              
Hit http://ubuntu.fastbull.org natty-backports/universe amd64 Packages         
Hit http://ubuntu.fastbull.org natty-backports/main amd64 Packages             
Hit http://ubuntu.fastbull.org natty-backports/multiverse amd64 Packages
Hit http://ubuntu.fastbull.org natty-backports/restricted amd64 Packages
Ign http://ubuntu.fastbull.org natty-backports/main TranslationIndex           
Ign http://ubuntu.fastbull.org natty-backports/multiverse TranslationIndex     
Ign http://ubuntu.fastbull.org natty-backports/restricted TranslationIndex     
Ign http://ubuntu.fastbull.org natty-backports/universe TranslationIndex       
Hit http://ubuntu.fastbull.org natty/main Translation-it                       
Hit http://ubuntu.fastbull.org natty/multiverse Translation-it                 
Hit http://ubuntu.fastbull.org natty/restricted Translation-it                 
Hit http://ubuntu.fastbull.org natty/universe Translation-it                   
Ign http://archive.canonical.com natty/partner Translation-en                  
Ign http://archive.canonical.com natty/partner Translation-it                  
Ign http://extras.ubuntu.com natty/main Translation-en               
Ign http://security.ubuntu.com natty-security/main Translation-en    
Ign http://security.ubuntu.com natty-security/main Translation-it
Ign http://extras.ubuntu.com natty/main Translation-it
Ign http://security.ubuntu.com natty-security/multiverse Translation-en
Ign http://security.ubuntu.com natty-security/multiverse Translation-it      
Ign http://security.ubuntu.com natty-security/restricted Translation-en      
Ign http://security.ubuntu.com natty-security/restricted Translation-it      
Ign http://security.ubuntu.com natty-security/universe Translation-en        
Ign http://security.ubuntu.com natty-security/universe Translation-it
Ign http://ubuntu.fastbull.org natty/main Translation-en
Ign http://ubuntu.fastbull.org natty/multiverse Translation-en
Ign http://ubuntu.fastbull.org natty/restricted Translation-en
Ign http://ubuntu.fastbull.org natty/universe Translation-en
Ign http://ubuntu.fastbull.org natty-updates/main Translation-en
Ign http://ubuntu.fastbull.org natty-updates/main Translation-it
Ign http://ubuntu.fastbull.org natty-updates/multiverse Translation-en
Ign http://ubuntu.fastbull.org natty-updates/multiverse Translation-it
Ign http://ubuntu.fastbull.org natty-updates/restricted Translation-en
Ign http://ubuntu.fastbull.org natty-updates/restricted Translation-it
Ign http://ubuntu.fastbull.org natty-updates/universe Translation-en
Ign http://ubuntu.fastbull.org natty-updates/universe Translation-it
Ign http://ubuntu.fastbull.org natty-proposed/main Translation-en
Ign http://ubuntu.fastbull.org natty-proposed/main Translation-it
Ign http://ubuntu.fastbull.org natty-proposed/multiverse Translation-en
Ign http://ubuntu.fastbull.org natty-proposed/multiverse Translation-it
Ign http://ubuntu.fastbull.org natty-proposed/restricted Translation-en
Ign http://ubuntu.fastbull.org natty-proposed/restricted Translation-it
Ign http://ubuntu.fastbull.org natty-proposed/universe Translation-en
Ign http://ubuntu.fastbull.org natty-proposed/universe Translation-it
Ign http://ubuntu.fastbull.org natty-backports/main Translation-en
Ign http://ubuntu.fastbull.org natty-backports/main Translation-it
Ign http://ubuntu.fastbull.org natty-backports/multiverse Translation-en
Ign http://ubuntu.fastbull.org natty-backports/multiverse Translation-it
Ign http://ubuntu.fastbull.org natty-backports/restricted Translation-en
Ign http://ubuntu.fastbull.org natty-backports/restricted Translation-it
Ign http://ubuntu.fastbull.org natty-backports/universe Translation-en
Ign http://ubuntu.fastbull.org natty-backports/universe Translation-it
Fetched 72 B in 2s (27 B/s)
Reading package lists... Done
N: Ignoring file 'getdeb.list.bck' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

raffaele@Natty:~$ LAN=en_US;sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
5 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = "it_IT:en",
    LC_ALL = (unset),
    LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up libgl1-mesa-glx (7.10.2-0ubuntu2.1) ...
update-alternatives: error: alternative link /usr/lib/xorg/extra-modules is already managed by x86_64-linux-gnu_gl_conf.
dpkg: error processing libgl1-mesa-glx (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of libglu1-mesa:
 libglu1-mesa depends on libgl1-mesa-glx | libgl1; however:
  Package libgl1-mesa-glx is not configured yet.
  Package libgl1 is not installed.
  Package libgl1-mesa-glx which provides libgl1 is not configured yet.
  Package libgl1-mesa-swx11 which provides libgl1 is not installed.
dpkg: error processing libglu1-mesa (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwxgtk2.8-0:
 libwxgtk2.8-0 depends on libgl1-mesa-glx | libgl1; however:
  Package libgl1-mesa-glx is not configured yet.
  Package libgl1 is not installed.
  Package libgl1-mesa-glx which provides libgl1 is not configured yet.
  Package libgl1-mesa-swx11 which provides libgl1 is not installed.
 libwxgtk2.8-0 depends on libglu1-mesa | libglu1; however:
  Package libglu1-mesa isNo apport report written because the error message indicates its a followup error from a previous failure.
                                                   No apport report written because the error message indicates its a followup error from a previous failure.
                                                                             No apport report written because MaxReports is reached already
                                                           No apport report written because MaxReports is reached already
                                          not configured yet.
  Package libglu1 is not installed.
  Package libglu1-mesa which provides libglu1 is not configured yet.
dpkg: error processing libwxgtk2.8-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-wxgtk2.8:
 python-wxgtk2.8 depends on libwxgtk2.8-0 (>= 2.8.11.0); however:
  Package libwxgtk2.8-0 is not configured yet.
dpkg: error processing python-wxgtk2.8 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of playonlinux:
 playonlinux depends on python-wxgtk2.8; however:
  Package python-wxgtk2.8 is not configured yet.
dpkg: error processing playonlinux (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libgl1-mesa-glx
 libglu1-mesa
 libwxgtk2.8-0
 python-wxgtk2.8
 playonlinux
N: Ignoring file 'getdeb.list.bck' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Sub-process /usr/bin/dpkg returned an error code (1)

raffaele@Natty:~$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 11.04 _Natty Narwhal_ - Release amd64 (20110427.1)]/ natty main restricted
deb-src http://ubuntu.fastbull.org/ubuntu/ natty restricted main #Added by software-properties
# deb cdrom:[Ubuntu 11.04 _Natty Narwhal_ - Release amd64 (20110427.1)]/ natty main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.


## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.



# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://it.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
# deb-src http://it.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse


## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu natty partner
deb-src http://archive.canonical.com/ubuntu natty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu natty main
deb-src http://extras.ubuntu.com/ubuntu natty main
deb http://ubuntu.fastbull.org/ubuntu/ natty main universe restricted multiverse
deb-src http://ubuntu.fastbull.org/ubuntu/ natty universe multiverse #Added by software-properties
deb http://security.ubuntu.com/ubuntu/ natty-security universe main multiverse restricted
deb-src http://ubuntu.fastbull.org/ubuntu/ natty-security universe main multiverse restricted #Added by software-properties
deb http://ubuntu.fastbull.org/ubuntu/ natty-updates universe main multiverse restricted
deb-src http://ubuntu.fastbull.org/ubuntu/ natty-updates universe main multiverse restricted #Added by software-properties
deb http://ubuntu.fastbull.org/ubuntu/ natty-proposed universe main multiverse restricted
deb-src http://ubuntu.fastbull.org/ubuntu/ natty-proposed universe main multiverse restricted #Added by software-properties
deb http://ubuntu.fastbull.org/ubuntu/ natty-backports universe main multiverse restricted
deb-src http://ubuntu.fastbull.org/ubuntu/ natty-backports universe main multiverse restricted #Added by software-properties
# deb http://ppa.launchpad.net/tobydox/ultrastardx/ubuntu maverick main
# deb-src http://ppa.launchpad.net/tobydox/ultrastardx/ubuntu maverick main
# deb http://ppa.launchpad.net/banshee-team/ppa/ubuntu natty main
# deb-src http://ppa.launchpad.net/banshee-team/ppa/ubuntu natty main
# deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu natty main
# deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu natty main
# deb http://download.virtualbox.org/virtualbox/debian natty contrib
# deb-src http://download.virtualbox.org/virtualbox/debian natty contrib

# deb http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu natty main
# deb-src http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu natty main
# deb http://archive.getdeb.net/ubuntu natty-getdeb apps
# deb-src http://archive.getdeb.net/ubuntu natty-getdeb apps
# deb http://ppa.launchpad.net/cdemu/ppa/ubuntu natty main
# deb-src http://ppa.launchpad.net/cdemu/ppa/ubuntu natty main
# deb http://ppa.launchpad.net/elementaryart/elementary-dev/ubuntu natty main
# deb-src http://ppa.launchpad.net/elementaryart/elementary-dev/ubuntu natty main
share|improve this question

1 Answer 1

up vote 2 down vote accepted

Can I suggest use ppa-purge to reinstate the standard ubuntu installation that had been upgraded by the PPA

i.e.

sudo ppa-purge ppa:elementaryart/elementary-dev

Edit:

from your revised trace there is this error: update-alternatives: error: alternative link /usr/lib/xorg/extra-modules is already managed by x86_64-linux-gnu_gl_conf.

This is described in this bug report - the suggested solution was to remove your nvidia driver from the Addition Drivers windows (deactivate it), make sure sudo apt-get update && sudo apt-get upgrade works before reactivating the nvidia driver again.

share|improve this answer
    
I've tried a few other python apps and now seems to work well... Seems to be a mesa problem (which should be different from nvidia opengl, I suppose). Playonlinux doesn't work anymore. Luckily the apps works with plain wine menu :D –  Hadden Aug 28 '11 at 17:04
    
I've disabled all PPAs but the wxgtk2.8 problem remains. If I would restore original settings of updating system? –  Hadden Aug 30 '11 at 11:01
    
please can you edit your question with the output of LANG=en_US;sudo apt-get update and LAN=en_US;sudo apt-get upgrade - please also include cat /etc/apt/sources.list - thanks. –  fossfreedom Aug 30 '11 at 12:17
    
@Hadden - have updated with latest info. –  fossfreedom Aug 30 '11 at 21:56
    
Now seems to work perfectly. I've disabled also the Nvidia PPA (most updated but less tested for ubuntu). Thank you for your help :) –  Hadden Sep 1 '11 at 10:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.