Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I fix this “E:Type '*' is not known on line * in source list …” update error?

I had a little problem with the sources of my update, I'm running Ubuntu Natty Narwhal and I was tinkering with binaries for installing a Firefox add-on called fire sheep and I think that some how my update sources were altered and evertime I try to upate I get this error message

An unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

'E:Type 'See' is not known on line 2 in source list /etc/apt/sources.list'
share|improve this question

marked as duplicate by htorque, Stefano Palazzo Jan 19 '12 at 23:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
According to the error message the second line of the file /etc/apt/sources.list is invalid. Could you please post that line? –  Florian Diesch Aug 28 '11 at 0:10

1 Answer 1

up vote 2 down vote accepted

I don't think it has anything to do with the add-on but I had a similar problem. Somehow your sources.list is modified on line 2. Do this:

Make a copy of your sources.list, just in case you need to revert the changes:

sudo cp /etc/apt/sources.list /etc/apt/sources.list_backup

Open the file with an editor, like:

gksu gedit /etc/apt/sources.list

In the second line you'll find the problem: That sentence:

See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to

has to be commented, otherwise the update manager will try to read it as a source and that's the error you are seing.

Simply add a # in front of that line. I should appear like this:

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to

If the problem persist, maybe because you have other lines with the same error, just correct'em all. But DON'T comment all the lines, first try to find which ones are wrong. Run update-manager each time and if there's an error it will tell you the line where it is.

Good luck!

share|improve this answer
    
alright :D ill try thanx man [ill come back with the results] –  blackstar Aug 28 '11 at 0:21
    
i tried what u suggested and it worked :) natty narwhal is updatyng perfectly fine now with now erroes :P thanx alot for your help –  blackstar Aug 28 '11 at 0:49
    
blackstar you should accept darent's answer and upvote it if it solved your problem ;-) –  Mark Rooney Aug 28 '11 at 1:26
1  
Glad to help. But still wondering what is causing the wrong format in sources.list We should open a bug if is not already opened,because this drove mad for days some months ago untill I saw the problem. See you. –  darent Aug 28 '11 at 10:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.