Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an original mac mini (pre-late 2005 model) that I bought at an auction. The computer was completely wiped clean. There were no disks given with the computer. I turn the computer on and it loads a gray screen with a folder in the center, blinking with the question mark and smiley face.

Here's what's I've tried.

I burned Ubuntu on to a cd using another computer and loaded it into the mini. I reset the computer and waited for the cd to load. The cd never loaded. I took the cd out and restarted the computer.

I made a USB install drive, following the instructions on Ubuntu's website. I turned off the mac mini. I inserted the USB into the mac mini. I turned on the mac mini while holding down the alt key. A purple screen comes on with two buttons, one for 'refresh' and one for 'next'. There are no other buttons or items on the screen (excluding the mouse).

My question: How do I install Ubuntu on this mac mini?

share|improve this question

migrated from apple.stackexchange.com Aug 27 '11 at 23:41

This question came from our site for power users of Apple hardware and software.

1  
Have you tried holding down the 'c' key when turning on the computer (to boot to the CD drive)? –  Nathan G. Aug 27 '11 at 17:55
    
Yes I tried that. It's not loading it. –  Mohammed Shareef Aug 27 '11 at 18:37
    
I just updated the question. USB install doesn't seem to be working either. –  Mohammed Shareef Aug 27 '11 at 18:38
1  
Just to be sure - Are you downloading the PPC image, not the Intel one? –  Gauzy Aug 27 '11 at 18:51
    
Ubuntu server version doesn't make any distinction except for 64bit and 32bit. I dl'd the 32bit. –  Mohammed Shareef Aug 27 '11 at 18:57

1 Answer 1

up vote 4 down vote accepted

You're trying to install i386 software on a PowerPC CPU. That's a completely different architecture, with a different instruction set -- they're not compatible.

Ubuntu has dropped official support for PowerPC a long time ago, but there are still community builds available. A good starting point is the Ubuntu Power PC FAQ.

share|improve this answer
    
This is a follow-up question to the awesome answer. Any download available for an Ubuntu Server?I see the download for Ubuntu 10.10 Maverick Meerkat. Does that include a server? –  Mohammed Shareef Aug 27 '11 at 20:28
    
Nevermind the comment. I found the answer. cdimage.ubuntu.com/ports/releases/lucid/release –  Mohammed Shareef Aug 27 '11 at 20:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.