Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have 11.04 installed with Gnome 3 and everything was working fine until I tried to run the update manager. Now I can't update any of my packages. A similar question was posted awhile ago but no solution was presented


Output from sudo apt-get update && sudo apt-get upgrade

Ign natty InRelease
Ign natty InRelease                        
Ign natty InRelease                     
Ign natty-updates InRelease                       
Ign natty-security InRelease                        
Hit natty Release.gpg                       
Hit natty Release.gpg                       
Hit natty Release.gpg                   
Hit natty-security Release.gpg            
Hit natty Release                           
Hit natty Release                                     
Hit natty-updates Release.gpg                     
Hit natty-security Release                 
Hit natty/main Sources                                
Hit natty Release                       
Hit natty/main Sources                                
Hit natty-security/main Sources                     
Hit natty/main i386 Packages                          
Ign natty/main TranslationIndex             
Hit natty-updates Release               
Hit natty/main i386 Packages                          
Ign natty/main TranslationIndex                       
Hit natty-security/restricted Sources               
Hit natty-security/universe Sources                 
Hit natty-security/multiverse Sources               
Hit natty-security/main i386 Packages               
Hit natty-security/restricted i386 Packages         
Hit natty/main Sources                  
Hit natty/restricted Sources            
Hit natty/universe Sources              
Hit natty/multiverse Sources            
Hit natty/main i386 Packages            
Hit natty-security/universe i386 Packages 
Hit natty-security/multiverse i386 Packages
Ign natty-security/main TranslationIndex            
Ign natty-security/multiverse TranslationIndex      
Ign natty-security/restricted TranslationIndex
Ign natty-security/universe TranslationIndex
Hit natty/restricted i386 Packages      
Hit natty/universe i386 Packages        
Hit natty/multiverse i386 Packages      
Ign natty/main TranslationIndex         
Ign natty/multiverse TranslationIndex   
Ign natty/restricted TranslationIndex             
Ign natty/universe TranslationIndex               
Hit natty-updates/main Sources          
Hit natty-updates/restricted Sources    
Hit natty-updates/universe Sources      
Hit natty-updates/multiverse Sources    
Hit natty-updates/main i386 Packages    
Hit natty-updates/restricted i386 Packages
Hit natty-updates/universe i386 Packages
Hit natty-updates/multiverse i386 Packages        
Ign natty-updates/main TranslationIndex           
Ign natty-updates/multiverse TranslationIndex
Ign natty-updates/restricted TranslationIndex
Ign natty-updates/universe TranslationIndex
Ign natty/main Translation-en_US            
Ign natty/main Translation-en_US            
Ign natty/main Translation-en               
Ign natty/main Translation-en               
Ign natty-security/main Translation-en_US 
Ign natty-security/main Translation-en
Ign natty-security/multiverse Translation-en_US
Ign natty-security/multiverse Translation-en
Ign natty-security/restricted Translation-en_US
Ign natty-security/restricted Translation-en
Ign natty-security/universe Translation-en_US
Ign natty-security/universe Translation-en
Ign natty/main Translation-en_US
Ign natty/main Translation-en
Ign natty/multiverse Translation-en_US
Ign natty/multiverse Translation-en
Ign natty/restricted Translation-en_US
Ign natty/restricted Translation-en
Ign natty/universe Translation-en_US
Ign natty/universe Translation-en
Ign natty-updates/main Translation-en_US
Ign natty-updates/main Translation-en
Ign natty-updates/multiverse Translation-en_US
Ign natty-updates/multiverse Translation-en
Ign natty-updates/restricted Translation-en_US
Ign natty-updates/restricted Translation-en
Ign natty-updates/universe Translation-en_US
Ign natty-updates/universe Translation-en

Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  brasero brasero-cdrkit brasero-common empathy empathy-common eog evince
  evince-common gedit gedit-common gnome-disk-utility gnome-keyring
  gnome-media gnome-shell gnome-system-monitor gnome-terminal
  gnome-terminal-data gnome-themes-selected gucharmap gvfs gvfs-backends
  gvfs-fuse libcanberra-pulse libcanberra0 libgcr0 libgdu-gtk0
  libgnome-keyring0 libgtk-vnc-1.0-0 libgucharmap7 light-themes
  linux-generic-pae linux-headers-generic-pae linux-image-generic-pae
  nautilus-sendto-empathy seahorse totem totem-common totem-mozilla
  totem-plugins vinagre yelp zenity
0 upgraded, 0 newly installed, 0 to remove and 42 not upgraded.

Edit 3

After installing each of the packages (via sudo apt-get install [package] ) that were held back, everything seems to be normal. So why did I have to reinstall everything? I'm assuming it has todo with gnome3 since every package was installed via their repo.

share|improve this question
thanks - and if, for example you type sudo apt-get install totem what error do you see? - again remember to add this back to your question. – fossfreedom Aug 27 '11 at 22:20
@fossfreedom Installed totem and running update && upgrade allowed me to update eog but the other packages are still being held back – smith324 Aug 27 '11 at 22:47
ok - step by step - lets find a package that is definitely being kept back - try installing the package with sudo apt-get install <packagename> - if it gives errors - replace the totem edit with this new package error. – fossfreedom Aug 27 '11 at 22:53

1 Answer 1

up vote 7 down vote accepted

I have found sometimes the package manager cannot cope with the extent of the changes a particular PPA is requesting to be updated.

For example, the manager starts processing a file, but gives up claiming wrong dependencies - without further analysing that a later package/or packages in the PPA would have fulfilled that dependency.

In these cases, you should do the following - run in a terminal

sudo apt-get update && sudo apt-get upgrade

This will give you a list of packages that it cannot install.

Go through the list one by one trying to install it i.e.

sudo apt-get install <package name>

Once you have done this, repeat the update/upgrade commands and repeat the remainder of the packages/new packages it is requesting. You may have to do this a few times until all the packages are installed.

share|improve this answer
Just wondering: as far as I recall, the 'Not all updates can be installed' message is usually accompanied by the option of 'Run partial upgrade'. As a GUI-way around that, would you (also) recommend running a "partial upgrade", rebooting, and then check if the Update Mgr has anything left to do after rebooting? Would your command-line method and this "GUI"-method amount to the same thing? Equally "safe"/reliable? – nutty about natty Jun 20 '13 at 8:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.