Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Somehow I messed up and accidentally made my usb stick into a read only file system. I have tried a bunch of things to delete the files, including the basic (rm -f myfile) and attempting to allow writing (sudo chmod +w myfile) and then deleting, but none of this seems to work. Any ideas on what I can do. I don't have anything on the usb stick that I need, but I don't want to throw away an otherwise perfectly good piece of equipment.

How can I make it work? Am I going about this completely the wrong way?

share|improve this question

3 Answers 3

up vote 7 down vote accepted

Commands like rm and chmod are done on a mounted file-system. So if the file-system is read only those do not work. What you need to do is to mount the file-system as writeable.

Some USB sticks have a switch on the stick to mount them read-only. Maybe that is the reason. It could also just be broken or damaged due to not correctly umounting it.

Before you do anything: copy the files over from the stick.

If it is not a hardware switch unplug and plug the USB stick and issue a

dmesg | grep -i panic

This will show you any panic messages. If you are seeing alot of them related to the USB stick and if it is a FAT partition you can use dosfsck to fix it.

You can find out how it is mounted with

mount

and use

dosfsck -a /dev/sd{xn}

to fix an MS-DOS partition table or sudo mkfs.vfat /dev/sd{xn} to format the disc. Where {xn} is a letter and digit you got with the mount command.

You can also use gparted to format it by the way.

share|improve this answer
    
I had to use sudo mkfs.vfat (I almost forgot to try that), but now it seems to work. Thanks. –  Jonathon Aug 28 '11 at 17:29
    
No need to thank me \o –  Rinzwind Aug 28 '11 at 17:30
1  
um.... this doesn't work if the usb stick is not formatted dos/fat but mine is formatted ext4... how do I make it mount writeable? –  Joshua Robison Aug 10 '12 at 6:35

I encountered this. The fault was corrupted partitions. Check your partition on the USB stick. This can get corrupted if you try formatting on Win and then on Ubuntu. use "gparted". You should see only 1 active partition. If you have an "unallocated" partition as well, the USB stick wont work. If so, delete all partitions, and create one active partition only for the full gb size of the usb stick. unplug then plug in again, and you should have R/W again.

share|improve this answer
    
This answer makes a bit more sense than the others in my particular situation. The extra partition laying around looks like the symptoms I have. –  Gustavo Carreno Sep 30 '12 at 18:24

Yes, if the filesystem is read-only, then setting modes on files will not have any effect at all. You can see in /etc/fstab if the filesystem is mounted read-only. But if you don't have anything on it, then you can also just make a new filesystem for it in gparted or palimpsest (the latter is installed by default in Ubuntu and is called Disk Manager or something).

share|improve this answer

protected by Community Oct 25 '12 at 22:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.