Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Im a new Ubuntu user, well new to Unix actually even if usually work with MacOS I had never really looked into it.

I installed Ubuntu on my laptop a few days ago and so far everything was going well, until all of a sudden the trackpad stopped responding. It does not move, nor it detects clicks.

Laptop is an Acer Aspire 5333-2880 running Ubuntu 11.04 64bits

After doing research I first thought the issue would be that my computer was not reading the trackpad, but doing:

 xinput list

output includes:

 ETPS/2 Elantech Touchpad id=12 [slave pointer (2)]

I then thought that it might have to do with kde, since some posts mentioned trouble with kde and trackpads, so I deinstalled kde and went back to Gnome, still with no results.

Since I've just started using this computer solely with Ubuntu and had no real data saved yet, I decided to reinstall Ubuntu, so that everything went back to place. I didn't have anything to loose really, anyway. Then again, the problem is still there.

If I plug a USB mouse, there is no problem using it. That's how I got around to reinstall Ubuntu and all.

The problem began after I installed pidgin along with a few other packages, like chess, Synaptic and the flash plug in for browsers; after I restarted my computer. I really don't know what else to do, I've been browsing through different forums online for hours without finding an answer.

I can't deny I've learned more about using the terminal than I would have by poking it around by myself, but this is getting really irritating and using a mouse really beats the purpose of a laptop (One of them anyway, at least that's the way I see it).

I hope someone can help me here, if you need any information form my hardware or terminal output just say so.

share|improve this question
This might be a kernel problem - have a look at this thread and run some of the suggested stuff in a terminal. If the output looks similar then you'll need either a custom build kernel - or wait for a fix when a new kernel is released in the future... – fossfreedom Aug 27 '11 at 17:29

I bought an Acer 5750-6421 and had the same problem with 11.04. The difference is that mine never worked from day 1 on both Gnome and KDE. I even tried another OS. I have been running 11.10 Oneiric Beta for a month and the Touchpad now works and also there are settings in the System Settings for Touchpad now, which did not happen in 11.04. So upgrade to 11.10 and that should fix that problem. I searched high and low with no other success. Now dimming the display is another matter. If you need that let me know.

share|improve this answer

Alt+Fn+F7 toggles the touchpad on and off.

share|improve this answer

try running this in terminal synclient TouchpadOff=0

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.