Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I click on a link to an email address in Firefox or Google Chrome a "Welcome to Evolution" screen appears. Can I make Gmail open instead, or at the very least disable Evolution from running?

share|improve this question

10 Answers 10

up vote 19 down vote accepted

You might want to take a look at an application called desktop-webmail Install desktop-webmail

It can be installed by clicking on the little icon next to the link or simply by executing following command:

sudo apt-get install desktop-webmail

Then go to "Applications > Internet > Desktop Webmail" and set your web email service. Finally go to "System > Preferences > Preferred Applications" and under "Mail Reader" set Desktop Webmail as your choice.

Desktop webmail supports following services: Gmail, Yahoo, Hotmail and Zoho

This could be a solution for other people as well that use other webmail providers.

Hope it helps :)

share|improve this answer
1  
Wow, that was easy. –  ændrük Oct 11 '10 at 16:48
    
Does that work in Unity because I still have only Evolution & Thunderbird under Preferred Applications!! –  Anas Mohamed May 3 '11 at 8:26
    
Yes, I believe this post is out of date. It doesn't work for me in Unity either. –  krumpelstiltskin May 4 '11 at 21:14
    
I can also verify that this no longer works in 11.04 –  grm May 4 '11 at 21:54
    
also doesn't work for me in 11.04 :( –  wim Aug 30 '11 at 5:33

Oddly, I couldn't find a simple way to do this in Lucid, so I wrote one:

cat ~/bin/mailto
#!/bin/sh
# mailto: a handler for mailto:[email protected] pseudo-uris

case $1 in
    mailto:*)   addr=`echo $1 | sed 's/^mailto://'` ;;
    *)          addr=$1 ;;
esac

url="https://mail.google.com/mail/?ui=1&view=cm&fs=1&tf=1&to=$addr"

# xdg-open suggestion courtesy of andrewsomething@askubuntu
exec xdg-open $url

Followed by a simple change in System ➤ Preferences ➤ Preferred Applications:

It has worked so well that I forgot I even had to write it until this question was asked.

share|improve this answer
1  
Very simple and elegant solution. You may want to consider expanding the script, packaging it, and offering it as an alternative software solution! –  Marco Ceppi Oct 11 '10 at 5:11
1  
@Marco: Good idea. If someone wanted to generalize it so that the browser isn't hardcoded, gconftool-2 --get /desktop/gnome/applications/browser/exec returns the default browser. –  andrewsomething Oct 11 '10 at 5:25
2  
Err... Better yet, just use xdg-open –  andrewsomething Oct 11 '10 at 5:26
1  
@andrewsomething: fixed and tested, thanks. One of my maxims is "a line of code that doesn't exist has no bugs"; you just reduced my possible defects by 9% ;) –  msw Oct 11 '10 at 5:43
    
+1 for versatility. I may end up using this later on. –  ændrük Oct 11 '10 at 16:49

In Firefox:

Go to Edit -> Preferences -> Applications

Select "mailto" in the "Content Type" list. Select "Use Gmail" in the Action list.

share|improve this answer
    
+1 for not using a script –  woohoo May 9 '12 at 16:39

If you are using Chrome, the Better Gmail extension will handle mailto links. It also tweaks a few other things about Gmail, but you can turn the rest off on the options page if you like.

A few other options that the extension provides are:

  • Hide Invite Friends Field.

  • Show Attachment Icons.-

  • Adds Row Highlight On Mouse Over.-

  • Unread Count in Favicon.-

share|improve this answer
    
the link doesn't work. –  wim Aug 30 '11 at 5:38
    
Updated with fixed link –  andrewsomething Aug 30 '11 at 16:05

In Chromium (and I assume Google Chrome as well) 17, it now gives you the option to use gmail as your email client:

enter image description here

And after clicking the "Use Gmail" button:

enter image description here

And it works!

share|improve this answer

GNOME Gmail will set itself as the preferred application, and also supports attachments (Send File... in Nautilus or LibreOffice). Install the gnome-gmail package.

share|improve this answer

For Firefox confer to this article on lifehacker:

  1. Open Gmail in Firefox.
    1. In the tab where Gmail is loaded, copy and paste the following snippet of JavaScript into your address bar:

      javascript:window.navigator.registerProtocolHandler("mailto","https://mail.google.com/mail/?extsrc=mailto&url=%s","GMail")
      
    2. If you are a Google Apps user, use this code instead, but replace example.com with your domain name:

      javascript:window.navigator.registerProtocolHandler("mailto","https://mail.google.com/a/example.com/mail/?extsrc=mailto&url=%s","GMail")
      
  2. Firefox 3 will ask permission to add Gmail as default mailto handler. Click the Add Application button, as shown.

share|improve this answer
    
This is completely unnecessary. As pointed out in this other answer posted at nearly the same time as yours, there is a Firefox preference now. –  Chan-Ho Suh Apr 13 '12 at 4:35

Desktop Webmail (package desktop-webmail in the default repositories) should solve the problem.

Desktop Webmail

share|improve this answer

HI Go to Firefox preferences and click on the Applications icon. scroll down the list to the mailto line and click on the right side of the table to display a drop-down menu. Select the program you wish to use. Cheers

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.