Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My system used to display the Full HD resolution - the native, very well on the Karmic.

I upgraded my system to Maverick and the maximum 16:9 resolution X server supports is 1280x720.

As far as I can remember, I didn't have to do any changes for the display back when I originally installed 10.04.

From the lspci, the graphics card I have is the one follows:

02:00.0 VGA compatible controller: ATI Technologies Inc Manhattan [Mobility Radeon HD 5000 Series]

How can I get back the high native resolution?

share|improve this question
    
Have you checked System > Administration > Additional Drivers? –  Marco Ceppi Oct 11 '10 at 4:25
    
Marco, Thanks, but the additional driver is installed, activated and currently in use. :( –  Lakshman Prasad Oct 11 '10 at 4:33
    
How did you determine that's the maximum supported resolution? Just that it's the highest thing listed in the graphical display tool? Or did wiki.ubuntu.com/X/Config/… fail for you? –  maco Oct 11 '10 at 18:10

5 Answers 5

Ok, not sure if I should delete the question. But I am sure some people may face same issue, so I will just answer it anyway.

Disable the additional driver, enable it and then restart, boom, everything back to normal!

share|improve this answer
    
Don't delete it. It helped me :) –  jb. Nov 11 '10 at 12:52
    
Had a similiar issue and came to the same conclusion. Thanks for posting it here so that I can see it confirmed here as well! –  Aron Rotteveel Jan 6 '11 at 11:01

Maye to extend Lakshman's post (could someone merge it into his response please): To have resolution properly detected I needed:

  • delete xorg.conf (it gets recreated then)
  • reboot
  • System -> Administration -> Additional drivers; and enable there FGLRX Driver
  • reboot
share|improve this answer
    
Thanks, this worked for me too! –  ztangent Jan 25 '11 at 7:28

Also try xserver-xorg-video-ati driver instead of fglrx. Fglrx caused problems with display resolution for me when I connected external monitor.

share|improve this answer

I have a similar problem only after the upgrade my Dell Studio laptop displays nothing but a purple screen. I can type my password in blind and hear it log in but nothing changes about the purple screen!

It's also an ATI gfx card.

Any ideas?!

share|improve this answer
    
This is not an answer in technical sense. It is not possible to answer you under this question title. The problem is not the same. I advice to start a new question if there's no same question. –  marenostrum Oct 21 '10 at 16:43

I have another computer, but graphic card vendor same (ATI). Try to install original driver by default(http://www.amd.com/uk/Pages/AMDHomePage.aspx) or try from menu System->Preferences->Monitor change monitor resolution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.