Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just decided to jump into the world of Ubuntu, so far I encountered no problems until I tried to connect to my wireless network. I'm running Ubuntu on my laptop, Acer Aspire 5333-2880, which has an Acer Nplify 802.11b/g/n wireless card. After browsing for an answer, I think the problem is a missing driver. input:

 lspci | grep Network

output:

02:00.0 Network controller; Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

I found a couple of answers that might be right, but I have problems with both of them.

  1. https://help.ubuntu.com/community/WifiDocs/Device/Atheros/AR9285 It requires me to load the site in my laptop, but I can't do it without internet and I have no idea how to save this into a USB.
  2. http://linuxwireless.org/en/users/Download/stable/ But I have no idea how to really run or use this, and I wouldn't like to screw it up.

Any advice or other possible solutions will be greatly appreciated!

EDIT.

Thanks a lot for your input Marko and Jorge. I am sure the problem was with one of the drivers, but I was too distracted, or tired yesterday to realize I didn't restart my computer after installing. As soon as I got turned on my computer again, it was working. Annoyingly, I am not sure what the problem was exactly nor what exactly fixed it.

But still, thanks a lot Marko for the intel on how to build packages, I am sure it will be very useful later on!

share|improve this question
add comment

3 Answers 3

Ubuntu has a tool to snag additional drivers for you. You need to plug the laptop into a wired network, and then run the "Additional Drivers" tool:

If this gives you problems please update your question with what happens.

share|improve this answer
add comment

Just go to synaptic and search for "linux-backports-modules-wireless-xxx-generic" or "linux-backports-modules-wireless-xxx-pae" depending on your Ubuntu version (run "lsb_release -c" to see your Ubuntu version) and kernel version (run "uname -r" command to see your kernel version) version. Then select right package like you're gonna install it and go to File -> Generate package download script and save it to /home/yourusername/Desktop like whatevername.txt.

Now open generated script with text editor and there you will have download links to all packages you need. Go to computer with internet connection, download .deb packages from links and then go to your laptop and install these packages by clicking on their icon. Then restart. Good luck!

share|improve this answer
add comment

You may find this question (How do I install a driver for an Atheros AR9285) useful.

Try the following possible solutions to this problem. Hope any one of them works for you:

  • Edit the following file /etc/modprobe.d/blacklist.conf and add this blacklist acer_wmi Then reboot and your wifi should work

  • Install the appropriate linux-backports-modules-cw-* package for your kernel, e.g.:

    • For Quantal, using Linux compat-wireless-3.6 backported to regular kernel sudo apt-get install linux-backports-modules-cw-3.6-quantal-generic and reboot

    • Same, but for Precise sudo apt-get install linux-backports-modules-cw-3.6-precise-generic and reboot

  • Install compat drivers

    1. Download this drivers: compat-wireless-3.6.8-1.tar.bz2
    2. Install the drivers:

      tar -xf /path/to/compat-wireless-3.6.8-1.tar.bz2

      cd /path/to/compat-wireless-3.6.8-1

      ./scripts/driver-select ath9k

      make

      sudo make install

    3. Reboot your computer.

If any of these doesn't work contact @m-cunille or @gertvdijk

While the thing which worked for me is not any of these. see here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.