Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to try SIP. However, I am having troubles with ekiga and upon looking them up it sounds like it is a NAT problem. Since I have control of both clients, I figured IPv6 would be much easier because I wouldn't have to worry about NAT. However, it sounds like Ekiga doesn't support IPv6. Is there a SIP client that supports IPv6 and is FOSS that runs on Ubuntu?

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

Empathy is installed by default and supports SIP. You'll need to install http://apt.ubuntu.com/p/telepathy-sofiasip.

share|improve this answer
    
I got it installed and it let me add my SIP account. However, on my laptop, which has to go through NAT for IPv4, it says network error. Both machines have IPv6 addresses. How do I get empathy to just use IPv6 and quit worrying about NAT? –  Azendale Aug 28 '11 at 14:59
1  
Good question. Make a new one. :) –  Jo-Erlend Schinstad Aug 30 '11 at 21:55
add comment

Ekiga isn't a client as such, but a provider. Think of them as the sip equivalent of Gmail. I think that any sip call has to go via a provider. So you want to find a provider that supports ipv6. I would guess that most of them do. These would all be paid services, but for calls to sip addresses with the same domain you might not have to pay anything.

share|improve this answer
add comment

Linphone (at least the version in 12.04) supports IPv6 or IPv4 (I don't think it does both at the same time).

If you go into the settings (Linphone > Preferences) and go to the Network Settings tab, there is a use IPv6 instead of IPv4 tab.

I tested doing a call directly between clients using an IPv6 address, and it worked.

Like daithib8's answer states, finding an IPv6 proxy/registrar (what he calls a provider) is another issue separate from what client you use.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.