I have 10.04.2 LTS and I want to install libglib2.0-dev. So I do:
$ sudo apt-get update && sudo apt-get upgrade $ sudo apt-get install libglib2.0-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libglib2.0-dev: Depends: libglib2.0-0 (= 2.24.0-0ubuntu4) but 2.24.1-0ubuntu1 is to be installed E: Broken packages
I don't understand from where the 2.24.1-0ubuntu1 version came out. The package details are:
$ apt-cache showpkg libglib2.0-dev Package: libglib2.0-dev Versions: 2.24.0-0ubuntu4 (/var/lib/apt/lists/ru.archive.ubuntu.com_ubuntu_dists_lucid_main_binary-i386_Packages) Description Language: File: /var/lib/apt/lists/ru.archive.ubuntu.com_ubuntu_dists_lucid_main_binary-i386_Packages MD5: f1a310bc28a3b8566d2f79a4116e8a0e
How can I fix it and install libglib2.0-dev?