Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 10.04.2 LTS and I want to install libglib2.0-dev. So I do:

$ sudo apt-get update && sudo apt-get upgrade
$ sudo apt-get install libglib2.0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libglib2.0-dev: Depends: libglib2.0-0 (= 2.24.0-0ubuntu4) but 2.24.1-0ubuntu1 is to be installed
E: Broken packages

I don't understand from where the 2.24.1-0ubuntu1 version came out. The package details are:

$ apt-cache showpkg libglib2.0-dev
Package: libglib2.0-dev
2.24.0-0ubuntu4 (/var/lib/apt/lists/ru.archive.ubuntu.com_ubuntu_dists_lucid_main_binary-i386_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/ru.archive.ubuntu.com_ubuntu_dists_lucid_main_binary-i386_Packages
                  MD5: f1a310bc28a3b8566d2f79a4116e8a0e

How can I fix it and install libglib2.0-dev?

share|improve this question
have you got the proposed repository enabled? Try unticking the proposed repository in software sources and do another update before trying to install. – fossfreedom Aug 25 '11 at 22:18
up vote 5 down vote accepted

Try to do it with aptitude:

sudo aptitude install libglib2.0-dev
share|improve this answer
Thank you. aptitude offered me to downgrade 2 packages and after I have accepted this solution the needed package was installed. – bessarabov Sep 18 '11 at 9:52
For me it was sudo apt-get install libglib2.0-0=2.24.0-0ubuntu4 (that will downgrade the package) and then sudo apt-get install libglib2.0-dev – Michal Kováč Feb 2 '13 at 23:56
Thanks Kovac, the downgrade helped – Muriuki David Mar 10 '14 at 7:18

You can install the needed version(= 2.24.0-0ubuntu4) and thus downgrade libglib2.0-0 which is of version (= 2.24.1-0ubuntu4).

sudo apt-get install libglib2.0-0=2.24.0-0ubuntu4

and now you can install the libglib2.0-dev

sudo apt-get install libglib2.0-dev
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.