Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I try install Mail server on Ubuntu, I've installed dovecot server.

telnet localhost 110 - correct

telnet mail.domain.cz 110 - correct

When I send email:

echo "Testicek" | mail -s "Dovecot test" [email protected]

And connect to the box [email protected], I found it, so it's correct.

But when I send email from outside (forexample Gmail), to [email protected] is returned:

The recipient server did not accept our requests to connect. Learn more at http://mail.google.com/support/bin/answer.py?answer=7720 [domain.cz (1): Connection refused]

In log isn't something error, so I don't know where I can find problem, but I think so, it can be in setting of domain:

   1800 A 31.31.73.***
 * 1800 A 31.31.73.***

Subdomains, etc. is correcly on apache (lamp) and send email via Squirrelmail is correct too.

Thanks for help!

share|improve this question

1 Answer 1

Port 110 is for POP3 which is only relevent for connecting to a POP3 server for downloading email.

For email to land on your server, you're talking about SMTP. This is what both your client and external relays use to move messages around the internet. SMTP uses port 25.

Dovecot has nothing to do with how emails land on your server. For this you need a Mail Transfer Agent like postfix. This is a SMTP server that will listen for external connections and route emails accordingly.

Install that from the command line (it'll walk you through some configuration options). You'll want to research the configuration because it can get a little complicated and you don't want to be an open relay (that is, you only want to accept email for your domains, and not forward on emails from spammers)

share|improve this answer
    
Yes, I have installed postfix. Maybe I found problem - when I try telnet localhost 25, it's correct, but from outside telnet domain.com 25, it's return Connection refused, but for telnet domain.com 110 its correct too –  frosty22 Aug 25 '11 at 10:26
    
Sounds like postfix or the firewall is the issue then. Assuming the firewall isn't an issue, you can reconfigure postfix with sudo dpkg-reconfigure postfix. Pick Internet site and make sure you specify the domains you want to handle email for. –  Oli Aug 25 '11 at 11:35
    
Thanks, I make reconfigure, but it still dont work ;( Only from localhost echo "Testicek" | mail -s "Next test" [email protected] –  frosty22 Aug 25 '11 at 13:32
    
I make dpkg-reconfigure postfix and now it works, but I think that setting is same - I don't know hot, but it works :) Thanks all! –  frosty22 Aug 25 '11 at 15:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.