Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First,I installed XP working. Second,I installed Ubuntu 10.10 64 bits working,and I have some disk space unused. Third,I boot into XP and use XP's tool to add one partition D. But when I reboot,the grub failed to boot. It shows

  grub rescue>

  ubuntu@ubuntu:~$ sudo fdisk /dev/sda

  WARNING: DOS-compatible mode is deprecated. It's strongly recommended to
     switch off the mode (command 'c') and change display units to
     sectors (command 'u').

  Command (m for help): p

  Disk /dev/sda: 640.1 GB, 640135028736 bytes
  255 heads, 63 sectors/track, 77825 cylinders
  Units = cylinders of 16065 * 512 = 8225280 bytes
  Sector size (logical/physical): 512 bytes / 512 bytes
  I/O size (minimum/optimal): 512 bytes / 512 bytes
  Disk identifier: 0xbfebbfeb

     Device Boot      Start         End      Blocks   Id  System
  /dev/sda1   *           1       38245   307202931    7  HPFS/NTFS
  /dev/sda2           38246       63290   201171969    5  Extended
  /dev/sda3           63290       77825   116754272+   7  HPFS/NTFS
  /dev/sda5           38246       38975     5859328   82  Linux swap / Solaris

  Command (m for help): 

How to fixed it?

I have tried to boot from ubuntu disk to run update-grub,

but I failed to run the following mount:

  ubuntu@ubuntu:/mnt$ sudo mkdir /mnt/disk
  ubuntu@ubuntu:/mnt$ sudo mount -t ext4 /dev/sda2 /mnt/disk
  mount: wrong fs type, bad option, bad superblock on /dev/sda2,
   missing codepage or helper program, or other error
   In some cases useful info is found in syslog - try
   dmesg | tail  or so

  ubuntu@ubuntu:/mnt$

PS:

1./dev/sda2 is my ubuntu ext4 partition

2.I can mount NTFS partition(sda1,sda3) without -t parameter,but only mount ext4 failed.

What can I do next? Thank you~

share|improve this question
    
what was the error message/ console output of the above commands? what does > sudo fdisk /dev/sda > print print out? –  Christian Aug 25 '11 at 8:31
    
I have already update my post to add fdisk info and my error mounting info. –  sam Aug 25 '11 at 8:37
    
Why I can mount NTFS,but can't mount ext4? –  sam Aug 25 '11 at 9:23
add comment

1 Answer

up vote 0 down vote accepted

The partition sda2 is an extended partition which is kind of a container for other partitions. the swap partition for example is contained in it, starts at the same block. there was probably another partition with linux in it but that one seems to be gone. It might work to just create a new ext4 partition in the remaining space of the extended partition but i doupt that the old data would still be there. you'd need lots of luck.

I assume that the XP partition tool somehow broke it because it's not aware of other operating systems with other partition types. In future always use the linux tools for partitioning. they don't bully windows partitions.

share|improve this answer
    
So is there any way to recovery grub,not reinstall any OS or install new Ubuntu? Thank you~ –  sam Aug 25 '11 at 9:11
    
I found the where is the error! When I put the ubuntu install disc to install ubuntu again,it shows the ubuntu partition is empty(200G)...So I know when I use XP's tool to add a partition,that tools will also erase my ubuntu partition... Thank you for above answers. –  sam Aug 25 '11 at 10:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.