Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have installed Eclipse through the Ubuntu Software Center on my new Ubuntu 11.04 laptop. I tried first using the stock openjdk-6-jdk package with it, but found it crashing on startup, so I removed openjdk6-jdk and eclipse and restarted with sun-java6-jdk package, but still got the same error.

The error from the error log is as follows:

!SESSION 2011-08-24 16:40:55.749
----------------------------------------------- eclipse.buildId=M20100211-1343 java.version=1.6.0_22 java.vendor=Sun Microsystems Inc. BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US Command-line arguments:  -os linux -ws gtk -arch x86

!ENTRY org.eclipse.osgi 4 0 2011-08-24 16:40:56.738 !MESSAGE Startup error !STACK 1 java.lang.IllegalArgumentException: invalid qualifier: 3+
        at org.osgi.framework.Version.validate(
        at org.osgi.framework.Version.<init>(
        at org.eclipse.osgi.framework.internal.core.Framework.initializeProperties(
        at org.eclipse.osgi.framework.internal.core.Framework.initialize(
        at org.eclipse.osgi.framework.internal.core.Framework.<init>(
        at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        at org.eclipse.equinox.launcher.Main.invokeFramework(
        at org.eclipse.equinox.launcher.Main.basicRun(
share|improve this question

closed as off topic by fossfreedom May 16 '12 at 15:21

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

I would say it's related to this bug, which is new and is caused by a kernel revision number that has + in it..

good luck!

share|improve this answer
Thanks your your answer, but I don't quite see how to fix my issue in that bug report. I do see a reference to a patch, but I don't know how to apply the patch they are talking about. I have run both apt-get upgrade and apt-get dist-upgrade. –  Dave Long Aug 27 '11 at 12:43
@DaveLong this is fixed upstream in Eclipse 3.6. –  Rinzwind Feb 23 '12 at 19:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.