Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just installed Ubuntu natty 64bit. Now I'm trying to install wine and no matter how I do it (Software center/synaptic/terminal), it fails.

Here's what I tried on terminal:

sudo apt-get update
sudo apt-get install wine

It shows:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.3 but it is not going to be installed
        Depends: ia32-libs (>= 1.6) but it is not going to be installed
        Depends: lib32asound2 (> 1.0.14) but it is not going to be installed
        Depends: libc6-i386 (>= 2.6-1) but it is not going to be installed
        Depends: lib32nss-mdns (>= 0.10-3) but it is not going to be installed
E: Broken packages

Any body faced this? Is this a bug or something is broken on my end?

Any hints on how to solve?

Edit:

I've tried with aptitude, it gives more clear message:

sudo aptitude install wine

Output:

The following NEW packages will be installed:
  gnome-exe-thumbnailer{a} ia32-libs{a} icoutils{a} imagemagick{a} lib32asound2{ab} lib32bz2-1.0{a} lib32gcc1{ab} lib32ncurses5{a} lib32nss-mdns{a} lib32stdc++6{ab} lib32v4l-0{ab} 
  lib32z1{a} libc6-i386{ab} libcdt4{a} libgraph4{a} libgvc5{a} libilmbase6{a} liblqr-1-0{a} libmagickcore3{a} libmagickcore3-extra{a} libmagickwand3{a} libnetpbm10{a} 
  libopenexr6{a} libpathplan4{a} netpbm{a} ttf-droid{a} ttf-symbol-replacement-wine1.3{a} ttf-umefont{a} winbind{a} wine wine1.3{a} wine1.3-gecko{a} winetricks{a} 
0 packages upgraded, 33 newly installed, 0 to remove and 0 not upgraded.
Need to get 135 MB of archives. After unpacking 421 MB will be used.
The following packages have unmet dependencies:
  libc6-i386: Depends: libc6 (= 2.12.1-0ubuntu16) but 2.13-0ubuntu13 is installed.
  lib32gcc1: Depends: gcc-4.5-base (= 4.5.2-2ubuntu3) but 4.5.2-8ubuntu4 is installed.
  lib32asound2: Depends: libasound2 (= 1.0.23-2.1ubuntu2) but 1.0.24.1-0ubuntu5 is installed.
  lib32stdc++6: Depends: gcc-4.5-base (= 4.5.2-2ubuntu3) but 4.5.2-8ubuntu4 is installed.
  lib32v4l-0: Depends: libv4l-0 (= 0.8.1-2) but 0.8.3-1 is installed.
The following actions will resolve these dependencies:

      Keep the following packages at their current version:           
1)      ia32-libs [Not Installed]                                     
2)      lib32asound2 [Not Installed]                                  
3)      lib32bz2-1.0 [Not Installed]                                  
4)      lib32gcc1 [Not Installed]                                     
5)      lib32ncurses5 [Not Installed]                                 
6)      lib32nss-mdns [Not Installed]                                 
7)      lib32stdc++6 [Not Installed]                                  
8)      lib32v4l-0 [Not Installed]                                    
9)      lib32z1 [Not Installed]                                       
10)     libc6-i386 [Not Installed]                                    
11)     wine [Not Installed]                                          
12)     wine1.3 [Not Installed]                                       

      Leave the following dependencies unresolved:                    
13)     wine1.3-gecko recommends wine1.3                              
14)     winetricks recommends wine1.2 | wine1.3 | cxoffice5 | cxgames5

It seems the wine package hasn't been updated in the repo. What should I do now?

share|improve this question
    
I suspect you have some confusion in your repos. I would see the content of /etc/apt/sources.list and the output of ls -l /etc/apt/sources.list.d/ –  enzotib Aug 24 '11 at 14:25
    
Hey! Thanks, I've removed ubuntu-wine ppa, selected main repository instead of the one from my country (not sure if that helped), now it is working! :) –  MHK Aug 24 '11 at 17:04
    
Have you installed the ia-32 libraries? because that seems to be the issue. –  Uri Herrera Aug 24 '11 at 17:04

3 Answers 3

up vote 3 down vote accepted

The main problem is you are using "Server for Bangladesh", means Bangladesh mirror. This mirror is not updated very regularly and users of this mirror faced this kind of problem several times including me. So change the mirror to Main Server or US server or anything.

share|improve this answer
    
Thank you Tareq! I already did that, just wasn't sure whether that actually solved the problem (mentioned that above in a comment). Just for testing, changed the mirror to ispros again and now gimp dependency is broken. Pathetic :( [Sorry I couldn't upvote your reply. Don't have enough rep :P] –  MHK Aug 24 '11 at 18:51

Try sudo apt-get install -f

That will install the dependencies.

share|improve this answer
    
Sorry, I forgot to mention. I've already tried that. Unfortunately the problem persists :( Here's the output of the command: Reading package lists... Done Building dependency tree Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. –  MHK Aug 24 '11 at 16:24

Dunno if you've solved this already since it's been awhile, but after a few hours of mashing my head against the keyboard doing stuff that didn't work (AAAAAAAH), I solved it as described here. I've included the relevant info below. Hope it helps!

On an Ubuntu system you can install the same dev packages that the packaged Wine uses from built-in package manager:

sudo apt-get build-dep wine1.3

If the build dependencies have changed recently, you may need to enable the Wine PPA to get an updated build-dep. Developers may want to enable the Wine PPA anyway, as it provides an updated wine-gecko package and sometimes newer versions of packages needed by Wine on older Ubuntus.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.