Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu server and then I wanted a GUI and I didn't want the server anymore. So I installed the GUI and every-time I restart my computer it goes to an Ubuntu loading screen which "loads" forever. I switch over to a virtual terminal and I execute startx which eventually gives me the login window. Unfortunately, when I tried to upgrade to 11.04 the update manager hanged for 20 minutes at (checking package manager) so I had to force reboot. I'm updating through the server command line and it's starting to get messy. I'm wondering if I could remove the server "part" or have to reinstall via the Live CD.

share|improve this question
Just a note: forcing reboot while upgrading your system usually cases lots of trouble. It's likely your system will be no longer usable and you will have to reinstall it (you have been warned, though, before upgrade began). If you are lucky you will be able to fix what was broken, but this may be very difficult and may cause serious long-term issues. – Rafał Cieślak Aug 23 '11 at 15:08
I'm upgrading to 11.04 right now with no issues, still upgrading though – alexy13 Aug 23 '11 at 15:47
You were right... There are errors ;O. Apparently dpkg is going into recovery mode to fix them though. I'll see what happens... – alexy13 Aug 23 '11 at 16:48
Its... Pretty much toast. Somehow xubuntu is installed and is messing things up, even though I removed it. I wish there was a command to fix packages or fix the system.... Xorg doesn't work, xstart doesn't work... – alexy13 Aug 23 '11 at 17:12
That's usual in case of interrupted upgrade. – Rafał Cieślak Aug 23 '11 at 18:53
up vote 1 down vote accepted

I solved the issue; kinda. Ubuntu was wayy too slow on my harddware, so I am currently installing a desktop version of PPC Lubuntu:

share|improve this answer
I doubt if that's an answer to this question! :) – Rafał Cieślak Aug 23 '11 at 18:53
I couldn't fix it pretty much. As you mentioned, it totally messed up the installation. – alexy13 Aug 23 '11 at 18:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.