Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed Guake and like it a lot. I'd like to set it as my preferred terminal application. That is, when I right-click on a bash script file, click "Open", and choose "Run in Terminal", I want it to open in a new Guake tab.

I'm not sure where to set Guake as the preferred app for "Run in Terminal". And I'm guessing that I might need the command to be something like guake --new-tab=new --execute-command="COMMANDHERE", so how do I pass that parameter?

Ideally, I'd like a terminal invocation to open a new Guake tab, unless there is already one available. (Difficult to tell, what id there's already a command running in the existing tab?) Failing that, just opening a new Guake tab is ok. Also, is there an option to keep Guake hidden when this happens?

Already tried:

Based on How can I set default terminal used? I have already tried:

  • gconftool --type string --set /desktop/gnome/applications/terminal/exec guake - this made Guake appear when I type Ctrl-Alt-T.

  • setting x-terminal-emulator to \usr\bin\guake in Alternatives Configurator - this made no difference (having already made the previous change).

share|improve this question
    
Hey d3vid, does this solution not help your set your default terminal? askubuntu.com/questions/70540/… –  Bruno Pereira Mar 12 '12 at 10:08
    
@BrunePereira thanks! that's given me partial success, but also highlighted that maybe I'm not asking for the right thing, so I've clarified my question –  d3vid Mar 13 '12 at 11:07
    
This question appears to be abandoned and unanswered. If you solved it, please post an answer explaining how it was solved (answering your own questions is not merely permitted, but encouraged when there is no other answer that does the job). If the question no longer applies you may voluntarily delete/close it. –  Eric Carvalho Jun 13 '13 at 23:53
2  
@EricCarvalho unfortunately still not solved - I'll see if I can contact Guake users/mailing list directly and post any response here as an answer –  d3vid Jun 18 '13 at 8:41

1 Answer 1

You could probably enjoy running gconf-editor — or maybe even dconf-editor since 12.04, — and navigate directly to the org.gnome.desktop.default-applications.terminal key:

dconf screenshot

The exec-arg parameter must be changed to Guake's -e. For the lazy:

gsettings set org.gnome.desktop.default-applications.terminal exec 'guake --new-tab'
gsettings set org.gnome.desktop.default-applications.terminal exec-arg '-e'
share|improve this answer
    
adding guake allows me to open/display guake when I click on Open terminal here in nemo. But I'm still looking for a solution to open/display guake with a new tab with the correct location. –  Nicolas Mar 16 at 18:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.