Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed versions 2.6.38~10 and 2.6.38~11 of the Linux kernel via apt-get and unfortunately neither one boots at all. As soon as I select the kernel in GRUB, the kernel panics and the CAPS LOCK key flashes. The latest version of the kernel that I have that boots is 2.6.38~8.

I have tried editing the boot parameters by removing quiet and splash but that does absolutely nothing.

What options do I have for debugging the kernel and finding out what is malfunctioning?

share|improve this question
1  
Have you tried booting into recovery mode? Do you actually see the kernel panic output on screen? –  htorque Aug 23 '11 at 7:15
    
might be that the new kernels are messing with your video drivers, what display drivers are you using? –  Dirk Hartzer Waldeck Aug 23 '11 at 10:20
    
@htorque: No, I don't see any output. –  Nathan Osman Aug 23 '11 at 16:24
    
@Dirk: The proprietary Nvidia ones. –  Nathan Osman Aug 23 '11 at 16:25

3 Answers 3

up vote 1 down vote accepted
+50

I had something similar to your case. Try the following:

  1. Boot 2.6.38~11 with recovery mode.
  2. From the recovery menu, choose "drop to shell with i-net access" (or something similar)
  3. type in the terminal: telinit 3 to switch to runlevel 3
  4. Enter your username, Enter password
  5. Type: sudo service gdm stop to close the x server.
  6. Type: sudo nvidia-installer -f --update ; this will download the latest driver and reinstall it.
  7. That's it, type sudo service gdm start and you have your desktop back.

At point 6 you don't really need to reinstall the driver. All you need is to build the module for your current kernel version, but i couldn't figured it out how to do it.

share|improve this answer

you need to re-run the NVidia .run file so that the new kernel modules will be built

the easiest way to do this would be to modify your boot parameters in grub

  1. when grub opens with a list of choices, press 'e' to edit the option
  2. select the second line(the one that starts with kernel) and press 'e' again to edit that
  3. goto the end of the line and add a space and a 3
  4. now press ENTER to save (i think just check the help at the bottom of the screen) and 'b' to boot

you should now be booted into a normal terminal on runlevel 3 so no graphics drivers are needed

cd to the directory where you've downloaded the NVidia .run fiel and run it again as root, remember to have it rerun nvidia-cconfig for you

if you reboot after that all should be well

this is unfortunately something you'll have to do every time you update your kernel

share|improve this answer

Remove the quiet and splash params, read the error messages that come up when booting fails.

Try the single or recovery boot option. I expect it fails during the loading of the kernel. If so then boot up into using a live disk mount your root partition. Search the contents of your [root-parition]/var/log/ directory. The kern.log, lastlog, boot.log, messages, debug, faillog and syslog could help. Paste them as part of your question to get more help.

Your error messages are added to the end of the log files. So it will usually be the last messages into the log file that you need to look at. But some times it will dump memory and such with is not as useful. So I would include the most obvious looking error messages or the last 50 lines to be safe.

share|improve this answer
    
There is no error message. –  Nathan Osman Sep 26 '11 at 17:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.