Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tend to download lots of articles as PDFs, and I find that when I browse a directory of these Nautilus takes 1 minute to load the directory. I assume that's because it's generating previews of their front pages. That feature is useless to me, alas.

I'd like to tell it not to do that.

share|improve this question
    
Have these vulnerabilities that you mention already been reported? –  WarriorIng64 Dec 12 '11 at 3:20

2 Answers 2

Assuming you're using Ubuntu 11.10, running the following in a terminal should do the trick:

gsettings set org.gnome.desktop.thumbnailers disable "['application/pdf']"

Alternatively, you can do this in the GUI by installing the dconf-tools package and running dconf-editor. In the tree on the left, navigate org → gnome → desktop → thumbnailers, then edit the disable option in the right pane as above.

I'm not sure what specific vulnerabilities you are trying to avoid (if they existed, I'd expect you could avoid them by installing the corresponding Ubuntu security updates), but the above should prevent generation of new PDF thumbnails.

share|improve this answer
    
In case you want to disable previews in general: gsettings set org.gnome.desktop.thumbnailers disable-all true should work, but it doesn't! Nautilus handles it according to it's own settings and eog ignores gsettings as well. –  isync Jan 11 '13 at 17:27
    
Until these bugs are fixed: rm -r ~/.thumbnails && ln -s /dev/null .thumbnails –  isync Jan 11 '13 at 17:35

In nautilus goto edit - preferences - preview and change the settings there.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.