Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a desktop machine with 11.04. It has ATI/Radeon graphics:

john@john:~$ lspci | grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc RS880 [Radeon HD 4250]

I was attempting to run some programs on Wine on it. It suggested using the proprietary driver if a had problems, which I did. I opened "Additional Drivers" and there it was: the FGLRX driver just waiting to be installed. I hit "Activate" and it installed, prompting me to reboot to complete the upgrade. I closed the window, opened the shutdown menu, and hit "Reboot to complete upgrade".

When it came back, it ran a disk check and froze on the purple screen with the word Ubuntu and the 5 dots. After about 15 minutes, I rebooted it. Same story. Thinking it was a fluke, I rebooted once more. This time, nothing. Zilch. Nada. I don't even see the BIOS. My monitor insists that there is no video coming from the computer. At all.

I've installed this driver before on an identical machine with no trouble at all.

I'm aware of this question, but that asker gets a black screen, I get no screen at all. I'm fairly sure I could fix this if I could just make it to a terminal, but no amount of keypresses (CTRL + ALT + F1, ALT + F2, holding SHIFT during boot) brought me anything.

What can I do?

share|improve this question
Do any of the status LEDs on the keyboard blink? (That typically indicates a kernel panic.) – Nathan Osman Aug 22 '11 at 19:22
@George No. They stay off the whole time. The machine gives one short beep, but that's it. – John Aug 22 '11 at 19:25
That's odd - a single beep from a BIOS typically indicates a successful boot. – Nathan Osman Aug 22 '11 at 19:27
@George That's what I thought, but everything else seems to suggest otherwise. – John Aug 22 '11 at 19:28
You're welcome - glad that fixed it! I'll convert my comments to an answer so that you can accept it. – Nathan Osman Aug 22 '11 at 19:57
up vote 4 down vote accepted

My suggestion would be to check for alternative outputs on your videocard (such as HDMI / S-Video) and try hooking up something to them to see if anything gets displayed.

share|improve this answer

I would suggest you to take a look at the answers on these questions, which may be helpful for you to find a clue on where to start.

Booting to no display

Posted here for your convenience:

The Ubuntu Wiki related to Troubleshooting BlankScreen provides useful information about why this problem occurs and how to fix it, which in my case solved my problem that was giving blank screen at the boot and I couldn't even see the Login Screen.

Related to what you refer about your issue, there is a part that reads just under "Non Symptoms":

If it occurs after entering your password on the login page, you have some different class of issue, such as an issue with 3D / DRM. Try disabling compiz (sudo chmod a-x /usr/bin/compiz), logging in as a different user, or turning off DRI.

However, I suggest you take a look at that document and check what of these can give you a clue on where to start for you to fix it.

Good luck!

System not reaching login on GUI

Also posted here for your convenience, even when it refers to the same thing.

The Troubleshooting Blank Screen at Ubuntu Wiki provides enough information about how to manage these issues, which I can't say what would fit your needs but take a look at that document in order to get a clue on where to start.

Quoted from the site:

If you see a screen of a different color (brown, white, multi-colored corruption, etc.) you are seeing a different class of graphics bug. Obtaining register dumps (see below) may still be of value however.

In my case what solved my problem was to edit the GRUB List at /boot/grub/grub.cfg and remove the "splash" parameter of each GRUB's entry, which may be different in your case as mentioned in the Wiki page:

To check this, in the grub menu edit the kernel line and remove 'splash' from the end of the line, and boot. If that solves the issue, you can remove it from your /boot/grub/menu.lst as a workaround.

NOTE: even when this document refers to the menu.lst file, that file doesn't exist inside my /boot/grub folder, which is grub.cfg in my case. (I can't say why but no need to comment about it)

Also Check the Analysis techniques section of the page in order to gather further information related to your specific issue and let us know, somebody may have more experience with your specific problem than I do.

Keep us posted on your issue.

Good luck.

P.S. You can edit your /boot/grub/grub.cfg using a live session CD/DVD but make sure you always keep a backup of your original file.

Somehow it seems that people is leading to this kind of issue, I can't say for sure but I guess it is caused by an update or something related to the installation of a software. In my case it was after updating my system and I solved as mentioned here: System not reaching login on GUI

Good luck!

share|improve this answer
I had found many similar suggestions, but my main problem was I had no way of trying them. I couldn't even get to a terminal. – John Aug 22 '11 at 20:04
You don't need to enter the terminal in your system. Try using a live session (Live CD/DVD, USB, etc.) and from there try to perform the procedure. I strongly suggest you to take a look at the steps in the Wiki page, which leads to the solution of the majority of these sisues, unless you are experiencing a different kind of issue (physical issue). Give the grub editing a try, in a live session navigate to the /boot/grub folder of your local drive and perform the steps that better fits your needs. Remember to keep a backup of your grub.cfg or any other file(s) you change. Go ahead & good luck. – Geppettvs D'Constanzo Aug 22 '11 at 20:07
I believe it was a physical issue, as George Edison's comment (posted before your answer) fixed it. Thanks for your suggestions. – John Aug 22 '11 at 20:13
Sorry to read that but fine you found a solution. :) Good luck! – Geppettvs D'Constanzo Aug 22 '11 at 20:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.