Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to follow these instructions, so that I could get the Citadel mail server to work alongside Apache, but I get an error when I try to restart Apache:

Invalid command 'ProxyPass', ...

I was told in the Apache docs that this is from the mod_proxy module, but apt-get install mod_proxy gives E: Couldn't find package mod_proxy, and I was unable to find it on the big list on the Apache site. What do I need to do to get the ProxyPass working in Ubuntu 10.04 TLS?

share|improve this question

2 Answers 2

up vote 32 down vote accepted

In the end I guessed that the module proxy_http in the mods-enabled directory might work, and used the command:

a2enmod proxy_http

My Proxy statements work now.

share|improve this answer

Try this link. Small example is given on how to install and do the basic url proxy.

share|improve this answer
    
This answer will be useless if that link goes down: askubuntu.com/help/referencing. Also, the debian/ubuntu way of enabling apache modules is a2enmod as stated in Lance's answer, not editing apache2.conf. –  Pete Oct 17 at 16:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.