Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hello I was wondering if anyone is having this same issue as I am, I am currently unable to change my brightness level on my laptop using the keyboard combinations to change the brightness level but I am able to do so with the slider with power manager settings (while using Gnome as DE the brightness applet won't work either).

I already change the grub kernel parameters to "quiet acpi_osi=Linux acpi_brightness=vendor splash" and all the similar combinations that people often suggest and I had no luck (actually those made it impossible to change the brightness even in the power manager settings).

Typing in a terminal...

pkexec /usr/sbin/gnome-power-backlight-helper --set-brightness 1

makes my brightness to go the lowest level and...

pkexec /usr/sbin/gnome-power-backlight-helper --set-brightness 10

the highest level.

I was wondering if anyone has had this same issue. I don't know if this helps but while using Fedora this issue does not happens, brightness keys will work perfectly fine.

share|improve this question
So, you've been trying to change your brightness on your laptop on you Ubuntu with your brightness keys on your keyboard. Your info is good, but it would be helpful to mention your model of your laptop. :) – mikewhatever Aug 22 '11 at 4:28
it is a HP DV6. Actually I believe that this bug will be solved with 11.10. I think this is a bug related to Gnome, with Fedora brightness keys work but with Fedora (15) I'm using Gnome 3 so I decided to boot with a older Fedora version, I've just tried with Fedora 13 (which uses gnome 2.something) and the same bug as Ubuntu happens. – José Antonio Aug 22 '11 at 4:57
I can't say for you, but for me it's a bug with switchable graphics. There's a custom kernel available that resolves the issue. Also, 11.10 did not fix this problem so his fork of the kernel still hasn't landed in the mainline. – Drew Sep 23 '11 at 1:44

Ubuntu Oneiric has better support for brightness function keys, you may want to try that.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.