Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed the gstreamer set of codecs, logged out, reboot, but Banshee still doesn't play my m4a files. Specifically, i installed

Gstreamer extra plugins Gstreamer plugins for mms, wavpack, quicktime, musepack Gstreamer plugins for aac, xvid, mpeg2, faad

Am i missing something else? a step or package?

  • gstreamer0.10-plugins-bad is installed
  • The movie plays fine in totem

It plays just fine on Totem! could it be because of the album artwork (which is showing as a "movie" and not being recognized by banshee?

share|improve this question
1  
Have you installed gstreamer0.10-plugins-bad? (sudo apt-get install gstreamer0.10-plugins-bad) –  desgua Aug 21 '11 at 23:39
    
Can other gstreamer-based players play the files, such as Totem (Movie Player)? –  michaelms Aug 22 '11 at 0:07
    
@desgua - yes it's installed. –  Dan Aug 26 '11 at 9:19
    
@MichaelMS - yes, it plays just fine on Totem! could it be because of the album artwork (which is showing as a "movie" and not being recognized by banshee?) –  Dan Aug 26 '11 at 9:20

2 Answers 2

Try to remove or rename the local configuration in your home directory. See the bug report. The workaround works for me.

rm -r ~/.gstreamer-0.10
share|improve this answer
1  
Seems to be some stale information. Deleting this does work. If you have presets you can be a bit more targeted and just run: rm ~/.gstreamer-0.10/registry.* –  Oli Nov 9 '11 at 16:00

Have you tried gstreamer0.10-plugins-ugly? After installing that and restarting Banshee, you might be able to play your files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.