Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an old laptop running as a server (It runs Ubuntu Natty).

When I SSH into the box, it often takes a long time to log on, if it's been a while since last time I logged on. I suspect the reason to be that the SSH daemon is put to sleep somehow, and has to be woken before I can log on. Can anyone explain why this happens?

Additional info

Besides SSHD the server runs Transmission Daemon and two Dropbox instances.

I have appended "UseDNS no" to /etc/ssh/sshd_config.

The machine is running a desktop kernel, because I use it as a backup desktop machine as well. Would it help to change it to a server kernel, or would that disable my desktop? I have read that there might be issues with nVidia drivers when running a server kernel, but don't know if this applies on Natty.

share|improve this question
    
You have a desktop system running servers? If so... this could be attributed to hibernate/suspend. At least that would be my 1st idea. –  Rinzwind Aug 21 '11 at 16:21
    
No, it doesn't suspend. There's no wake-on LAN, and Transmission is seeding constantly. –  beruic Aug 21 '11 at 21:17
1  
if transmission is seeding it may just be a congested network problem. –  Smithamax Aug 22 '11 at 8:59
    
Well, it might. However, I have a limit on so it only uses ~60% bandwidth. –  beruic Aug 22 '11 at 12:56
add comment

1 Answer

Adding the "-v" parameter to the "ssh" client will give you visible output as to what is going on in the SSH handshake. This will help you identify where it is stalling. One common option to disable on the server is the following in "/etc/ssh/sshd_config"

GSSAPIAuthentication no
share|improve this answer
    
I know about the -v (and -vvv) option, but didn't know about that option. Will test thoroughly. –  beruic Aug 23 '11 at 20:20
    
It seems to be always slow at "debug1: Entering interactive session.". I will try the option. –  beruic Aug 26 '11 at 16:55
    
Seems like I didn't post my other comment. The option is already commented out. Other than that, it seems to be very connecting that is the issue, so the daemon could be sleeping. –  beruic Aug 29 '11 at 15:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.