Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed ubuntu alongside windows but grub wont show during boot and windows starts instead.

I used a liveCD and followed these instructions

https://help.ubuntu.com/community/Boot-Repair

But they didn't help.

So here is the Boot info summary http://paste.ubuntu.com/671345/

If more info is necessary don't hesitate to ask. Thanks

August 22 Edit: I use the standard windows 7 bootloader... windows came preinstalled on the desktop. I have yet to successfully boot into ubuntu on this machine. with the exception of live CD.

share|improve this question
    
You don't see the menu because Grub is not in the MBR, and nothing apparently points to it. What bootloader do you use to boot Windows? Have you install EasyBCD? –  mikewhatever Aug 21 '11 at 3:39
add comment

2 Answers 2

The problem is probably due to the wrong partition being booted when the computer starts.

To fix this boot from a live CD ( for my instructions you will need a version before 11.04 has gparted was removed from 11.04, 10.10 will be fine)

  • Open system -> administration -> gparted partition editor
  • Check witch partition is flagged with boot Partition flagged with boot if the partition flagged with boot is ntfs (File System column) it probably means the computer boots into windows without passing by grub. (If it is not marked with ntfs do not continue with my instructions)

To fix this right click on your the ext4 (File System column) (the Ubuntu partition) manage flags and select boot.

Restart your PC and you should be presented with the grub menu.

If your computer refuses to boot after proceeding with the above steps, reboot from the live CD and mark the lately flagged ntfs partition back with boot.

share|improve this answer
    
I am sorry, but IMHO, none of that will help. There is a lot of stuff, so I won't go into too many details, just mention - updating grub from a CD won't update grub on the partition, boot flags are for Windows (grub doesn't care about them). –  mikewhatever Aug 21 '11 at 18:03
    
I thought about the problem of sudo update-grub I had read it on a ubuntu forum thread by reading on you are right it doesn't work. Are you sure about your flag stories I had a similar problem (installing grub on a separate partition and changing the flags where enough to solve the problem). Can you think of a way of correcting this post or do you suggest I just delete it? –  danjjl Aug 21 '11 at 18:28
    
Check out the Wikipedia article on boot flags. secure.wikimedia.org/wikipedia/en/wiki/Active_partition –  mikewhatever Aug 22 '11 at 1:13
add comment

You could try pointing the "boot" flag for the drive to the Ubuntu partition. I had to do this for my installation, in order to preserve the ability to use the GRUB Bootloader.

You can use gparted for this. But you will have to do it from a LiveCD in order to prevent the drive from being mounted/used actively.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.