Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem

No picture appears on the second, externally, connected monitor.

All used to work perfectly until a week ago or so. I always used nvidia-settings + TwinView/Clone to clone my laptops view, but now nothing happens and Ubuntu freezes, gets garbled and unresponsive when I try to clone it.

50 USD bounty is promised to whoever drops the magic words that will fix this for me, granted you accept PayPal. I rely on dual-screen setup on this machine for my work and really need it to work·

Screenshots

These show some of the settings in nvidia-settings and also how garbled the screen becomes. Notice that the external screen (in this case the Samsung) shows nothing and is just black all the time. It does however detect it has an attached cable to it since the monitor says "No signal" when I disconnect the cable from my laptop to it.

enter image description here

enter image description here

Symptoms

  • External monitors are always detected properly, problem occurs when I try to actually activate them.
  • Upon activation in nvidia-settings (or anything else) the system freezes. A garbled picture is shown on the laptop screen and no picture is shown on external monitor.

Hardware

  • MacBook Air 3,2
  • GeForce 320M (GPU 0)

Software

Already tried

14th of August 2011:

  • List item
  • Reinstalled the nvidia drivers and using the ones Ubuntu chooses in restricted drivers box.
  • Reinstalled xorg.
  • Deleted all GNOME2 settings and got a fresh GNOME2.
  • Connected the computer to several different external monitors, all which used to work, but with same zero result. (This all works in another OS on the same computer, so it's not hardware issues.)
  • Shut off Compiz - no change.

20th of August 2011:

  • Reinstalled ubuntu-desktop and all dependencies for it, I see no change.
  • Installed latest NVIDIA prop dirvers 280.13. Status quo.
  • Tried creating new user accounts and testing other already existing accounts: Same result.
  • Tried disper & xrandr Same freeze occurs.

21th of August 2011:

  • Completely re-installed the whole OS, but this time I went with LinuxMint 11 (Katya, 64). The problem remains.
share|improve this question
    
Issue is now resolved: The problem was the display port to VGA adaptor. Once I swapped it out for a brand new one it all fixed itself. –  snowdrop Aug 28 '11 at 0:21
    
Please add your solution as an answer and accept it instead of writing a comment. –  N.N. Sep 19 '11 at 20:19

1 Answer 1

The problem was the display port to VGA adaptor. Once I swapped it out for a brand new one it all fixed itself.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.