Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Edit: it fixed itself, but I have no idea how...

I have a new laptop running Ubuntu 11.04. If I have certain USB devices (a wireless mouse, or my camera, but not a USB flash drive) plugged in to any of the computer's USB ports, Ubuntu won't boot. (They work fine as long as I plug them in once I can see an Ubuntu splash screen.) It gets to GRUB, and if I run in recovery mode, it starts booting, then freezes at about 2 seconds, and goes to a black screen. (Without recovery mode, it just does the black screen.)

Ctrl+Alt+F1 does nothing; I also can't ssh into it at this point. Removing kernel options quiet splash from GRUB did nothing except give a "Loading, please wait..." message with the USB not plugged in; the same for replacing them with noapic. My BIOS has no "legacy USB" option that I can find.

Nothing I can find in /var/log is updated when this happens, so I have no logs.

Any ideas?

share|improve this question

closed as too localized by Bruno Pereira Feb 26 '12 at 22:11

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Did you check logfiles for errors? (/var/log/boot.log and /var/log/boot for instance). Re-installing grub might be an option. – Rinzwind Aug 20 '11 at 22:20
I see no errors, but that may be because they're being overwritten when I reboot again (with mouse unplugged to get back to a useable system). – Ben Kraft Aug 20 '11 at 22:36
Boot, wait for it to crash. Turn system of and then use a live cd to look at /var/log. That way your log files should be useable IF the system even gets there to write an error ;) – Rinzwind Aug 20 '11 at 22:39
Tried that; all of the files are from the boots before the crash. I assume it's not getting to the point where it writes the logs. – Ben Kraft Aug 20 '11 at 23:22

You could do the folllowing: You could disbale the USB ports until the boot ends and then activate the USB ports: I think you could do this via vim.

cd /etc/default
sudo vim acpi-support
Change the module line the following:

I am really not sure if this works and if this has the consequence that your USB ports doesn't work anymore I will not take that on me. I would recommend this solution only experts who could redo this. Only works if you got usbcore. Some peaople haven't got it. You should first test if you have got it:

$ ls -l /lib/modules/`uname -r`/kernel/drivers/usb/usbcore.o*

Could also work with this folder: /usr/src/linux-your-version/drivers/usb

This could work because: If you start ubuntu your usb devices are of course off but after the boot they should of course be activated like after a suspend. I had this problems ones with an laptop. It would also be very cool if you tell us your exactly laptop model because it could have other reasons.

share|improve this answer

Your do nousb as grub boot command and activate it after boot but I don't know how to. Or maybe easier disable acpi support and do a quit splash should work with: ro quiet splash noapic

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.