Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Fonts totally unreadable

I have this problem: I see rectangles in the places where should be text. This happens, for example in Code::Blocks in the build log tab, in the warning lines, the rest of the text is OK. This also happens in certain message boxes of Ubuntu. And in the subtitles text in the default video player, some lines, not all.

Here is an image of the rects:

enter image description here

share|improve this question

marked as duplicate by Marco Ceppi Aug 22 '11 at 17:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What locale do you use? If it is something unique like Japanese or something, you may be missing fonts or language support packages. –  RolandiXor Aug 20 '11 at 15:42
    
@Rinzwind I didn't try to remove it, I was trying to make it link to the full sized image. It worked in the preview at least... –  Alvin Row Aug 20 '11 at 16:02
    
I have a similar problem when i move code from a mac to a linux! have you done that? :) –  Alvar Aug 20 '11 at 16:50
    
Do you have the same problems if you use english as language? :) –  Alvar Aug 20 '11 at 16:51
    
I use the english-usa locale. I didn't move code from a mac to a linux. –  Néstor Pan Aug 20 '11 at 16:59

2 Answers 2

up vote 1 down vote accepted

Solved! I reinstalled the Ubuntu fonts with this command:
apt-get install --reinstall ttf-ubuntu-font-family

Then I rebuilt the font information files with this command:
fc-cache -f -v

And Solved the problem! :) I found the solution in another question: Fonts totally unreadable

share|improve this answer

What is the encoding of the file? The default on ubuntu is UTF8 if the files are encoded in a different encoding that is not recognised the unrecognised characters are replaced with blocks.

share|improve this answer
    
This is not a file, this is a program. It uses UTF8, and that is the encoding of my Ubuntu. This not only happens in that program, but also in the subtitles on totem movie player, and in some message boxes of Ubuntu. –  Néstor Pan Aug 20 '11 at 23:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.