Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Just did an upgrade on my laptop from 10.04 to 10.10, and audio doesn't work at all anymore. I have the indicator applet, and it seems like everything is working fine. I've even tried installing several mixers in case something is muted, but nothing is (and mixers are showing activity as if everything is working fine).

No application is reporting any errors, they all seem to be playing happily, but no sound comes out. I've tried reinstalling PulseAudio with --purge but that didn't help either.

(If you need any logs or command output please let me know in the comments, I don't know where to look..)

Things tried so far:

  • Creating a new user to eliminate any configuration problems
  • Creating /etc/asound.conf with these instructions
  • sudo apt-get install libxine1-ffmpeg
  • Booted from a live CD (10.04) to eliminate any hardware problems
share|improve this question

Have you tried to create a new Ubuntu user just for testing, to see if it is some config causing the trouble?

Try this:

share|improve this answer
Tried adding a new user, no dice. Did you mean I should try creatig /etc/asound.conf or something else from your link? – dr Hannibal Lecter Oct 10 '10 at 23:47
@dr-hannibal-lecter Edit your question with the updated things you have tried so that it doesn't get buried in the comments. – Jorge Castro Oct 11 '10 at 0:06
@Jorge: Edited, sorry about that. – dr Hannibal Lecter Oct 11 '10 at 0:15
No need to apologize! Check the faq to see how editing your questions and adding more details helps you get your problem fixed quicker: – Jorge Castro Oct 11 '10 at 0:21
Yes, have you tried the /etc/asound.conf ? – lovinglinux Oct 11 '10 at 0:27

try sudo apt-get install libxine1-ffmpeg

share|improve this answer
Nope, still nothing :( – dr Hannibal Lecter Oct 11 '10 at 22:08
up vote 0 down vote accepted

Did some more research and found a "solution".

After a lot of googling, finally ran into this launchpad bug:

After seeing comment #39 mentioning my laptop model, I've modified my alsa-base.conf and restarted. In more detail:

  1. sudo vi /etc/modprobe.d/alsa-base.conf (or some other editor instead of Vi)
  2. Append the following at the end of the file:

    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=auto
  3. Reboot

Warning: These instructions should only be used with the models mentioned in the launchpad bug discussion and not just on any configuration.

To be honest, I'm not sure what the lines above actually do, but my noob instinct tells me it helps ALSA detect the proper sound card model and load the appropriate driver.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.