Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I performed a sudo apt-get install lamp-server^ on my Ubuntu 10.10 desktop for development purposes and then installed Webmin. Now, Webmin doesn't seem to think Apache is running when it really is, and if I try to start Apache from the Webmin interface I get the following output:

Failed to start apache :

 * Starting web server apache2

Also, through Webmin, if I try to view the Apache error log I get this:

cat: /var/log/apache2$SUFFIX/error.log: No such file or directory

Whatever is going on is preventing me from using name-based hosting to view local sites. What is wrong and how do I fix it?

share|improve this question
up vote 4 down vote accepted

As can been seen from the first paragraph of the webmin documentation on the Ubuntu Wiki and Launchpad, webmin is no longer supported in Ubuntu. Instead, users are being pointed to eBox. The same issue was reported on the forums and was determined to be an issue with Webmin that needs to be resolved.

The issue was reported as a bug against Webmin here:

The fix seems to be to edit /etc/apache2/envvars, to quote jcameron:

Ok, thanks .. I see the issue now. The fix is to remove $SUFFIX from the lines :

export APACHE_PID_FILE=/var/run/apache2$ export APACHE_RUN_DIR=/var/run/apache2$SUFFIX export APACHE_LOCK_DIR=/var/lock/apache2$SUFFIX export APACHE_LOG_DIR=/var/log/apache2$SUFFIX

as it will be empty anyway.

So you have 3 options:

  1. Use eBox
  2. Patch the file yourself to resolve the issue
  3. Wait for the Webmin maintainer to fix the bug and new packages to be released.
share|improve this answer
Thanks, I found most of this information out after doing some independant research. However, the news of Webmin no longer being supported by Ubuntu is new. – PHLAK Oct 19 '10 at 16:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.