Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've set up a server with Ubuntu 11.04 and Nginx+PHP-FPM+Varnish+APC+MySQL+Memcached+WordPress. Everything runs pretty nice, but there is a tiny problem with the PHP-FPM service. Install goes OK after the usual

apt-get install php5-fpm

But when you start the service, there is a problem with the config file. It seems that comes from the Debian package, that uses certain directory (/var/www) that it is used there, but not by default in Ubuntu. So each time I restart the service, I get this:

# service php5-fpm start
 * Starting PHP5 FPM...
Aug 19 20:57:31.622788 [WARNING] [pool www] pm.start_servers is not set. It's been set to 20.
   ...done.

It's looking for a config file that I don't have, or that I have but PHP5-FPM doesn't find.

How to solve the problem? Where do I have to put the right config file for PHP-FPM??

share|improve this question

1 Answer 1

From the OP:

Looking for more config files I've finally found the one that allows me to set the right parameters. It is

/etc/php5/fpm/pool.d/www.conf

There you can find most of the parameters needed to restart PHP-FPM with the settings anyone can need. I've tested it and after the edition of the file the service runs according to the new parameters.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.